0

A LAN network resource configuration issue:

Ubuntu 16.04 server/workstation, Ubuntu 16.04 client/laptop. Same two users on both, let's say A and B. Samba is installed on both machines. On the server, A and B are established as Samba users with the same passwords as each has on the system. A server/workstation directory is specified as a writable Samba share with access granted to both users, and is established as a Local Network Share with both users granted create and delete permissions.

Here's the problem: One can access the network share on the server/workstation from the client/laptop using A's credentials but not B's. The shares are obviously visible and accessible, just only with one set of credentials. What we need is for each user to be able to access the network directory with his own credentials, not others'.

Any thoughts on causes and solutions would be most appreciated.

  • Because (a) I have no idea what either is; and (b) no option to implement either appears available in the file browser. All that is available is (i) Connect to Server; and (ii) the so-called "Local Network Share" or "Folder Sharing" dialog boxes that on their face appear to allow folder sharing. Both, as noted, fail. – ebsf Dec 28 '16 at 23:24
  • See the Ubuntu to Ubuntu section of my answer to this question. Aslo see Network File System help. – user68186 Dec 28 '16 at 23:28
  • Thanks. I tried the network setup you describe and it failed. Some tinkering reveals that the specific SAMBA fail is that users can view SAMBA shares with their own credentials but can only access SAMBA shares with the directory owner's credentials. I'll be noting this general failure in a separate post and will attempt to link this post to it. – ebsf Dec 29 '16 at 14:55
  • Somehow, I can't edit my own comment. My revised comment is: – ebsf Dec 29 '16 at 15:02
  • 1
    If this is a bug in samba, please file a bug report. Bugs are off topic here. I suggest, openssh and sftp as a simpler solution than NFS. – user68186 Dec 29 '16 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.