I'm trying to understand how to install the ffmpeg package from Launchpad.

The ffmpeg website links to that page when you try to download it for Linux.

  • Actually I can't find that exact Launchpad link anywhere on that page. What you appear to be looknig for is on this page
    – Elder Geek
    Dec 28, 2016 at 17:57
  • 1
    You haven't said what you want to do with ffmpeg, but the published binaries can be a little restrictive due to the different licences used in some libraries. You may want to compile ffmpeg to get the functions that you need -- this is a useful guide of how to compile ffmpeg with various options. Dec 28, 2016 at 19:13
  • 1
    Please add what release of Ubuntu you are using, i.e., Trusty (14.04), Xenial (16.04), Yakkety (16.10)
    – doug
    Dec 28, 2016 at 19:31
  • 1
    @doug Sorry, I am using Kubuntu 16.04 and I want to download it for Paraview. The reason I want to download it from launchpad is because the Launchpad
    – shinvu
    Dec 29, 2016 at 9:22
  • @ElderGeek The third link on that page "Ubuntu - Official packages for Vivid, Wily, Xenial" links to the webpage I gave.
    – shinvu
    Dec 29, 2016 at 9:25

4 Answers 4


ffmpeg is available in the official Ubuntu repositories :
- xenial | xenial-updates | yakkety | yakkety-updates -

apt policy ffmpeg
  Installed: 7:3.0.5-0ubuntu0.16.10.1
  Candidate: 7:3.0.5-0ubuntu0.16.10.1
  Version table:
 *** 7:3.0.5-0ubuntu0.16.10.1 500
        500 http://archive.ubuntu.com/ubuntu yakkety-updates/universe amd64 Packages
        500 http://archive.ubuntu.com/ubuntu yakkety-security/universe amd64 Packages
        100 /var/lib/dpkg/status
     7:3.0.2-1ubuntu3 500
        500 http://archive.ubuntu.com/ubuntu yakkety/universe amd64 Packages

To install it open a terminal and execute this command :

sudo apt install ffmpeg  

There is no need to download ffmpeg from launchpad.

Update addressing your comment about missing packages after an installation using apt

When you install ffmpeg using apt, the 'additional packages' are getting installed alongside automatically, maybe something went wrong in your case. For example - here my initial setup - these packages were installed after I had executed the command sudo apt install ffmpeg :

ffmpeg (7:3.0.2-1ubuntu3)
i965-va-driver (1.7.1-1)
libaacs0 (0.8.1-1)
libass5 (0.13.2-1)
libavcodec57 (7:3.0.2-1ubuntu3)
libavdevice57 (7:3.0.2-1ubuntu3)
libavfilter6 (7:3.0.2-1ubuntu3)
libavformat57 (7:3.0.2-1ubuntu3)
libavresample3 (7:3.0.2-1ubuntu3)
libavutil55 (7:3.0.2-1ubuntu3)
libbdplus0 (0.1.2-1)
libbluray1 (1:0.9.3-2)
libbs2b0 (3.1.0+dfsg-2.2)
libchromaprint0 (1.3-1build1)
libcrystalhd3 (1:0.0~git20110715.fdd2f19-11build1)
libdc1394-22 (2.2.4-1)
libflite1 (2.0.0-release-2)
libgme0 (0.6.0-3)
libgsm1 (1.0.13-4)
libmodplug1 (1:
libmp3lame0 (3.99.5+repack1-9build1)
libopenal-data (1:1.17.2-1)
libopenal1 (1:1.17.2-1)
libopenjpeg5 (1:1.5.2-3.1)
libpostproc54 (7:3.0.2-1ubuntu3)
librubberband2v5 (1.8.1-6ubuntu2)
libschroedinger-1.0-0 (1.0.11-2.1build1)
libsdl1.2debian (1.2.15+dfsg1-4)
libshine3 (3.1.0-4)
libsoxr0 (0.1.2-1)
libssh-gcrypt-4 (0.7.3-1)
libswresample2 (7:3.0.2-1ubuntu3)
libswscale4 (7:3.0.2-1ubuntu3)
libtwolame0 (0.3.13-1.2)
libva1 (1.7.1-2)
libvdpau1 (1.1.1-3ubuntu1)
libx264-148 (2:0.148.2699+gita5e06b9-1)
libx265-79 (1.9-3)
libxvidcore4 (2:1.3.4-1)
libzvbi-common (0.2.35-11)
libzvbi0 (0.2.35-11)
mesa-va-drivers (12.0.3-1ubuntu2)
mesa-vdpau-drivers (12.0.3-1ubuntu2)
va-driver-all (1.7.1-2)
vdpau-driver-all (1.1.1-3ubuntu1)

This is from an Ubuntu 16.10 installation - packages and versions are different in other editions.
Other packages like libavcodec-extra57, which provides some additional de/encoders or any dev-versions have to be installed manually. If you are still running Ubuntu 14.04, you can install libav-tools (a fork of ffmpeg which temporarily replaced ffmpeg in Ubuntu 14.04) instead.

  • Actually, I need ffmpeg as a pre-requisite for Paraview. I tried the apt based installation, but it doesn't install number of important other things (libavcodec, libavutils, libavdevice, libavformat, and libswscale).
    – shinvu
    Dec 29, 2016 at 9:33
  • The page on Launchpad listed all of those other things as bundled with the package, so I wanted to download it from there.
    – shinvu
    Dec 29, 2016 at 9:33
  • Thanks for the update. I re-did the apt based installation. To check if the other packages were installed alongside it, I ran the command sudo find / -name "avcodec.h" (it should return the location of the header file avcodec.h that is supposed to be installed with the package libavcodec), I get nothing. So that confirms that the other packages aren't being installed.
    – shinvu
    Dec 30, 2016 at 14:57
  • Do you have any ideas about what might be causing the other packages to not install? I am doing all of this on Kubuntu 16.04, not Ubuntu 16.04....could that be the source of the problem (I know that sounds stuipid, but I really can't think of anything I'm doing differently than you)?
    – shinvu
    Dec 30, 2016 at 15:01
  • @user3595843 : You can check whether the libav related packages are installed by running : dpkg --get-selections | grep libav ... alternatively you can do it with : apt policy <package-name> for each package ! :)
    – cl-netbox
    Dec 30, 2016 at 15:01

You copied the Ubuntu - packages for Vivid, Wily, Xenial link from the ffmpeg website incorrectly. The correct link is: https://launchpad.net/ubuntu/+source/ffmpeg. At this webpage you can show the ffmpeg .deb packages that are available to be downloaded by unfolding the white triangles on the left side of the page. The ffmpeg packages at this website were last updated two weeks ago.

In Ubuntu 12.04, 16.04, 16.10, 17.04, 17.10 and 18.04 and later (but not 14.04) you can also install ffmpeg from the terminal with the following command:

sudo apt-get install ffmpeg  
  • I opened the white triangle, but it gives separate .deb files for each of the software listed. Is there any way to install all of the listed software in one go? I'm assuming there should be a way to do this, otherwise why would they present all of these software together as one package?
    – shinvu
    Dec 29, 2016 at 9:38
  • Some of the packages on the list of .deb software are mutually incompatible, so that if you install one of the packages of the pair of incompatible packages, you will get an error message if you try to install the other one. The simplest way to avoid this type of problem is to install the packages carefully, one package at a time. It takes longer, but it's safer to install the packages that way.
    – karel
    Dec 29, 2016 at 9:58

Precompiled binaries of Paraview don't need or use ffmpeg libs so I'll assume that you are looking to build Paraview with ffmpeg support.

In that case this should do it, it will install all 9 -dev packages. Likely that you don't need them all, if desired remove the last package to get a shortlist of 4 -dev packages.

sudo apt install libavcodec-dev libavformat-dev libavdevice-dev

It doesn't hurt to have a couple of extra -dev's installed & many sources will only use what they need/support.


To download a program off of launchpad

First look for the packaged deb file for your version of Ubuntu (a deb for Debian/Mint etc may work for Ubuntu - RPMs are for fedora/centos/redhat/suse, other packaging formats are available for different distros). This can a annoying to find on launchpad (the link may just be out of date) - but is still possible to something usable (NOTE: Read the last part of the answer before trying for ffmpeg...):

  1. Go to Code at the top
  2. Get the most relevant branch (e.g. vidid/ffmpeg for 15.04)
  3. Find a 'recipe' with successful builds (example) then download the deb files for that (example) - get amd64 if possible for 64bit, else use the i*86 packages (for 32bit).

If you can't find that, you can usually get a source code download (e.g. for 14.04, here - the ffmpeg site version is https://www.ffmpeg.org/download.html). You then should be able to compile and install that - instructions are available here, and usually in a README file in the stuff you download. Please note that if you do not use checkinstall etc, you may need to remove the package with sudo make uninstall or similar to remove the compile program, hence why it is usually better to use packaged versions

Too add a PPA

Launchpad can better used with PPAs, instructions for using them can be found here.

FFmpeg Specifically...

The method you use to install ffmpeg depends on the version of Ubuntu you are using. For recent supported versions (since 15.04 (vivid), so 16.04 & 16.10 currently), this should work and will get ffmpeg from the offical repos (here):

sudo apt-get install ffmpeg

However if you are using 14.04 (and some other versions from around that point), you can use libav-tools a fork of that project

sudo apt-get install libav-tools

This was because ffmpeg was removed from the offical ubuntu repositories for a few versions. however ffmpeg is still available from third party sources for them (such as ffmpeg source code, PPAs, and deb downloads. This is covered extensively here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.