0

I have a new Lenovo Thinkpad E560, running Windows 7. I installed Ubuntu 16.10, creating partitions for root, home, tmp, and swap. A partition called "bios_grub" was created automatically.

Now whenever I boot the system it boots to Windows 7. My boot menu does not seem to be from grub, it shows only four items:

Windows
ATAPI CD0 – boots from DVD
ATA HDD0 – does nothing
PCI LAN – does nothing

My question is not "how do I install Ubuntu". I have done that several times, without any major problems. This time, however, although Ubuntu has been installed on my disk, it does not appear in the boot menu.

I booted from an Ubuntu live DVD and ran boot-repair but it tells me it cannot deal with a BIOS boot, only UEFI. So I tried to change the Windows boot to UEFI. The result is no booting system at all, with the following message:

File: \EFI\Microsoft\Boot\BCD
Status: 0xc000000d
Info: An error occurred while attempting the boot configuration data.

When I changed the boot menu back to BIOS Windows worked again. No Ubuntu boot option.

The file \EFI\Microsoft\Boot\BCD exists on the EFI system partition, and the partition is flagged as "boot" and "esp" (shown by gparted). There is no other partion flagged as "boot". The disk is GPT. The Windows partition administration says the partition has status "no errors (EFI system partition)". It is the first partition on the disk.

I see two possible ways to proceed:

(1) Can I change my Windows boot to UEFI, so I can run boot-repair successfully?

(2) Alternatively, is there a way to get a dual boot (grub or whatever) running with BIOS?

Any help is appreciated. Please inform me if there is more information I should provide.


Edit: Output from "sudo lsblk -f":

NAME    FSTYPE    LABEL   …
sda
├─sda1    vfat    SYSTEM_DRV                 …
├─sda2
├─sda3    ntfs    Windows7_OS …
├─sda4    ntfs    Lenovo_Recovery …
├─sda5
├─sda6    swap …
├─sda7    ext4 …
├─sda8    ext4 …
├─sda9    ext4 …
├─sda10   ext4 …
sr0    tso9960    Ubuntu 16.04.1  LTS amd64      … /cdrom
loop0    squashfs         …    /rofs

sudo lsblk -fm additionally gives the following sizes:

sda    931.5G
sda1   100M    
sda2   128M
sda3   232.9G
sda4   14G
sda5   95M
sda6   14.9G
sda7   9.3G
sda8   14.9G
sda9   540.2G
sda10  105.1G

I installed Ubuntu 16.10 from a live DVD, which I booted via the second item in my boot menu (ATAPI CD0). How can I "start installer in UEFI mode", as oldfred suggested? If I can do that, maybe it resolves my problem.

Sorry, I cannot answer in a comment (size limitation), so I have to edit my original question.


@ubfan1's hint to change my boot options from "BIOS first" to "UEFI first" solved my problem. I re-installed Ubuntu after changing this, and now I have a Grub menu. – ubfan1, if you re-enter this as an answer rather than a comment I will gladly give you credit.

6
  • 5
    The installer detects whether the system is booted via EFI or not and typically installs appropriate to the method you booted in. Changing your Windows boot is likely to be considered off topic here. The Boot menu you are describing is the BIOS boot menu which is accessible before GRUB. Perhaps this full HOWTO will assist you in properly installing Ubuntu: askubuntu.com/questions/6328/how-do-i-install-ubuntu
    – Elder Geek
    Dec 27, 2016 at 14:09
  • 2
    This computer, where I type this comment, is dual booting in BIOS mode, so it is possible. Please describe how you installed Ubuntu - which tool you used and more details about the partitions. It is enough with three partitions in a GPT disk: the bios_grub partition, the linux root partition and the linux swap partition, but it should be possible with partitions for home and tmp too. Please post the output of 'sudo lsblk -f' and 'sudo lsblk -fm' in your question, so that it can be formatted by indenting (with 4 blank characters).
    – sudodus
    Dec 27, 2016 at 14:14
  • How you boot install or repair media UEFI or BIOS is then how it installs or repairs. If you have the /EFI/Microsoft and gpt then Windows has to be booting in UEFI boot mode. Most Windows 7 systems were BIOS and all pre-installed Windows 8 are UEFI. But some Windows 7 systems are UEFI. If it asked for a bios_grub partition you installed Ubuntu in BIOS mode. start installer in UEFI mode, install Boot-Repair and run advanced mode total uninstall/reinstall of grub. That will convert your install to UEFI. sourceforge.net/p/boot-repair/home/Home
    – oldfred
    Dec 27, 2016 at 15:55
  • First, thanks for the speedy answers. I might add that this is not my first Ubuntu installation; I have been using Ubuntu for aroung eight years (am writing this on my "old" PC under Ubuntu) and haven't had the problem described above so far.
    – Renardo
    Dec 28, 2016 at 18:44
  • 1
    Lenovo may have an UEFI settings/BIOS option of selecting "legacy before UEFI" or "UEFI before legacy". Since the install media has both boot mechanisms, you should select the UEFI first option to boot it in UEFI mode.
    – ubfan1
    Dec 28, 2016 at 19:40

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.