1

I need to run some js from a webpage, but when it tries to load I got the error of the subject topic. I'm running ubuntu 14, FF 50xx, and latest version of java.

But, that part of the page that came from a .cgi works on FF 41, mint 14xx and:

java version "1.7.0_79" OpenJDK Runtime Environment (IcedTea 2.5.6) (7u79-2.5.6-0ubuntu1.14.04.1) OpenJDK Client VM (build 24.79-b02, mixed mode, sharing)

I ran FF 41xx and didn't work. I download the exact same version of java: openjdk-7-source_7u79-2.5.6-0ubuntu1.14.04.1_all.deb

Purged everything else : apt-get purge openjdk-* icedtea-* icedtea6-*

And then I installed the 7u79xx with gdebi, but instead I got the:

java version "1.7.0_121" OpenJDK Runtime Environment (IcedTea 2.6.8) (7u121-2.6.8-1ubuntu0.14.04.1) OpenJDK 64-Bit Server VM (build 24.121-b00, mixed mode)

Even when I manually removed the deb packages of 7u121xx version, I guess that aptitude looked up for newer versions and downloaded them. Anyhow, this didn't work either.

I read another article about it, but I don't have some files that requires java to run on /usr/bin (speaking of extracting the files from a *.tar.gz).

I'll try now to install the 7u79xx package without updating the package to the 7u121.

I appreciate it if someone can give me a hand on how to make this run. Thanks!.

0

Update:

Worked on my default FF 50.1.0 BUT, now it says:

setup failed please install 32 bit java and update...etc.

So, I got to this article : How to install Juniper VPN on Ubuntu 14.04 LTS?

-

I'm now using:

java version "1.7.0_79" Java(TM) SE Runtime Environment (build 1.7.0_79-b15) Java HotSpot(TM) 64-Bit Server VM (build 24.79-b02, mixed mode)

update-alternatives --config java

loading java from: 1 /opt/jdk/jre1.7.0_79/bin/java 100 manual

Then,

I realiaze that I didn't have a FF java plugin going trough a FF tab and -> about:plugins

-

So, after reading this: How to install the Java plugin for Firefox?

I did this:

apt-get install icedtea-7-plugin

The result (FF tab -> about:plugins) :

IcedTea-Web Plugin (using IcedTea-Web 1.5.3 (1.5.3-0ubuntu0.14.04.1))

File: IcedTeaPlugin.so
Path: /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64/IcedTeaPlugin.so
Version: 
State: Enabled
The IcedTea-Web Plugin executes Java applets.

-

I'll try now the first article that I've mentioned on the beginning of this post and I'll post the results.

0

Well, the thing turned out to be that the juniper VPN client don't get along with 64 bits systems, so, there is a bunch of documentation, scripts, etc.

Such as: How to install Juniper VPN on Ubuntu 14.04 LTS?

http://mad-scientist.us/juniper.html

Juniper Network Connect not working on ubuntu 16.04

Since I was about to already reinstall my OS, I'll decide to go for a 32 bit OS, I'll use it only for work, so it's okay. I don't want to have plenty of both 32/64 versions of FF, JAVA, plugins, etc. Since I would had to do that in order to get this run properly.

0

To future readers, this worked that time on: 64 bits Xenial / FF 47 and 32 bits Xenial / FF 51, quite old now but could give you a hint on the how to:

Install specific java version:

apt-get install openjdk-7-jdk:i386

If you don't have the repos, do:

add-apt-repository ppa:openjdk-r/ppa  
apt-get update

Choose which java to use:

update-alternatives --config java

There are 3 choices for the alternative java (providing /usr/bin/java):

  Selection    Path                                            Priority   Status
------------------------------------------------------------
  0            /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java   1081      auto mode
  1            /usr/lib/jvm/java-7-openjdk-amd64/jre/bin/java   1071      manual mode
* 2            /usr/lib/jvm/java-7-openjdk-i386/jre/bin/java    1070      manual mode
  3            /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java   1081      manual mode

*Noticed that I checked option 2: /usr/lib/jvm/java-7-openjdk-i386/jre/bin/java

Install FF icedtea plugins:

apt-get install icedtea-plugin

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.