1

Connected my old HDD with usb dock to my computer after migrating to SSD. I was dual booting on that HDD now I want to use it as my storage disk. Yet it has 9 partition connected with Windows or Ubuntu. Gparted was able to delete some of them but some are not allowed to turn into unallocated space. There is a key symbol next to those. I can access every disk so it seems healthy but can't format and converge all of them to one partition. Here is how it seems:

PS: I don't want to preserve any data.

Partition Table for my external HDD

picture1

  • Since you're on Linux right now have you tried to unmount those partitions showing still a mount-point? You can do that in terminal if needed with sudo umount <mount-point>, or with right clicking the entries in your partition list. – Videonauth Dec 26 '16 at 12:26
  • Yeah it worked out after manually mounting all of them. I created new partition table and parameter error gone. Thanks! – kirbiyik Dec 26 '16 at 12:40
  • O.k. then let me add an answer. – Videonauth Dec 26 '16 at 12:41
1

As I can read of your screen-shot the partitions are still mounted in your Linux, open a terminal with ctrl+alt+t and unmount them with issuing the following command for each partition which still shows a mount-point:

sudo umount <mount-point>

Or as alternative you can right click their entries in the partition list and select unmount.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.