I'm using Gnome Shell in Ubuntu 11.10. I ran into a problem with Ubuntu when I tried to share my network connection. It sat at connected, failing, connected, failing, continuously. Because the connection was not fully working, the "configure" button was grayed out. I was unable to select it in order to go into IPv4 settings and switch it back to regular DHCP.

The fix? Logged out, logged in to another desktop environment which contained the features I needed, and switched it back.

Wow. Really?

Why are these features missing? Why can I NOT select "configure" at any time I want? This is extremely counter productive.


gnome-shell's network applet is a bit unfinished.

You can either:

  1. disable the gnome-shell's network applet, reverting to the old network-manager applet (nm-applet).

  2. run nm-connection-editor to edit the connection (or right click the network icon).

To disable gnome-shell's network-manager applet. Type the following into a terminal:

sudo mv /usr/share/gnome-shell/js/ui/status/network.js /usr/share/gnome-shell/js/ui/status/network.disabled

Then reload gnome-shell either by executing (via alt+F2) the command r or from the command line by running gnome-shell --replace

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.