I've noticed a new release of Picasa (3.9). How would I install it over my current install of Picasa?

  • 1
    If you have problem with installing:<BR>env WINEARCH=win32 WINEPREFIX=~/.tmp winetricks ie6 change it to <BR>env WINEARCH=win32 WINEPREFIX=~/.tmp winetricks ie7 – Tomasz Matoga Aug 15 '12 at 8:52
  • some shells don't like the env. As I use ZSH on 64 Bit WINEARCH=win32 WINEPREFIX=~/.tmp winetricks ie7 worked for me. – math Nov 1 '12 at 9:17
  • 1
    I have just managed to install Picasa 3.9 in my Ubuntu 12.04.2 LTS 64 bit machine. In order to be able to login to my Google account properly, I installed IE8 using the fast track suggested by @desgua with a slight modification: sudo apt-get install wine winetricks && cd ~/ && wget http://dl.google.com/picasa/picasa39-setup.exe && wine ~/picasa39-setup.exe && env WINEARCH=win32 WINEPREFIX=~/.tmp winetricks ie8 && cp -r ~/.tmp/* ~/.wine/ – regeirk Jun 6 '13 at 23:33

To install Picasa 3.9

1) Install wine and winetricks:
sudo apt-get install wine winetricks

2) Download Picasa 3.9 from google:
cd ~/ && wget http://dl.google.com/picasa/picasa39-setup.exe

3) Install Picasa with wine:

wine ~/picasa39-setup.exe  

To fix login

Now you have Picasa 3.9 installed but there is a problem if you want to login to Google to upload some pictures, so to fix it do this:

4) Install Internet Explorer 6:
env WINEARCH=win32 WINEPREFIX=~/.tmp winetricks ie6

You will have to click "Next" and "Accept" in a few windows:

enter image description here

5) Copy the installation into wine folder:
cp -r ~/.tmp/* ~/.wine/

6) Done! Now just open Picasa as any other program:

Open Dash and search for Picasa. Click at the top right corner to login:

enter image description here

enter image description here

I) With this method each user will have to run the steps 2 to 5 to get Picasa fully working into his/her user folder. Or ask for he/she to run this once at terminal:

 cd ~/ && wget http://dl.google.com/picasa/picasa39-setup.exe && wine ~/picasa39-setup.exe && env WINEARCH=win32 WINEPREFIX=~/.tmp winetricks ie6 && cp -r ~/.tmp/* ~/.wine/    

II) If you are feeling lazy, just paste this at terminal and all the steps above will be done for you (as a user specific installation):

 sudo apt-get install wine winetricks && cd ~/ && wget http://dl.google.com/picasa/picasa39-setup.exe && wine ~/picasa39-setup.exe && env WINEARCH=win32 WINEPREFIX=~/.tmp winetricks ie6 && cp -r ~/.tmp/* ~/.wine/  

III) After the step 5, the file "picasa39-setup.exe" can be deleted:
rm ~/picasa39-setup.exe

And also the folder "~/.tmp":
rm ~/.tmp

IV) To uninstall everything:

sudo apt-get remove --purge wine ; sudo apt-get remove --purge winetricks ; sudo apt-get autoremove ; sudo rm /usr/share/applications/Picasa3.desktop ; rm ~/picasa39-setup.exe ; rm -r ~/.tmp ; rm -r ~/.wine ; rm -r ~/.local/share/applications/wine* ; sed -i '/wine/d' ~/.local/share/applications/mimeinfo.cache
  • The step env WINEARCH=win32 WINEPREFIX=~/.tmp winetricks ie6 did not work for me: wine cmd.exe /c echo '%ProgramFiles%' returned empty string --- If I try only winetricks ie6 then I get: "This package does not work on a 64-bit installation" – Felipe Jun 23 '15 at 18:37
  • I tried to use this script for installing google photos auto backup (which replaced picasa) but it didn't work. Im getting "there was a problem authenticating your account". Any chance you know if this can be fixed? – Shoham Jun 25 '15 at 17:45
  • i think the problem is the 2 step authentication with Google. Installing ie6 with WINE was a workaround but ie6 isn't installing in some setups. – desgua Jun 28 '15 at 16:47
  • There is a way to do it with google photos auto backup ... basically you just export & import some registry records from a windows installation to Ubuntu. Full instructions here if someone interested: askubuntu.com/questions/602555/… – Shoham Jul 5 '15 at 20:26
  • 2
    The Picasa 3.9 binaries are no longer available, but preserved at archive.org at this link here: web.archive.org/web/20160823080900/https://dl.google.com/picasa/… – Wayne Piekarski Sep 28 '17 at 22:54

If you use Picasa 3.9, you will not be able to connect to your Google account. According to Google employee Brian Rose, the authentication mechanism was changed to OAuth using an implementation that is currently not compatible with Wine.

There is an entry in Wine's AppDB for Picasa 3.9, and I submitted a bug report. As a workaround, install Internet Explorer 6 using Winetricks. You have to use the upstream Winetricks script, since the one packaged in Ubuntu has a broken Internet Explorer link.

wget http://winetricks.org/winetricks
chmod +x winetricks
WINEPREFIX=~/.wine ./winetricks ie6
  • 1
    Great instructions. Instead of IE6.0 work around for google account login. I tried an application specific password using the following link. Worked for me. The link: google.com/accounts/IssuedAuthSubTokens – user41528 Jan 11 '12 at 18:50
  • "This package does not work on a 64-bit installation" – matt burns Jan 5 '15 at 12:52

PlayOnLinux supports Picasa 3.9:


PlayOnLinux is a graphical front-end for the Wine software compatibility layer which allows Linux users to install Windows-based video games, as well as many other applications such as Apple iTunes, Safari, Microsoft Office, Microsoft Internet Explorer.


wget -q "http://deb.playonlinux.com/public.gpg" -O- | sudo apt-key add -
sudo wget http://deb.playonlinux.com/playonlinux_trusty.list -O /etc/apt/sources.list.d/playonlinux.list
sudo apt-get update
sudo apt-get install playonlinux

Search and do what the wizard says:

League of Legends under Ubuntu - EuroBytes Image from: League of Legends under Ubuntu - EuroBytes.


protected by Community Jul 7 '12 at 17:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.