5

I am having a hard time making my webcam work for Ubuntu on Vmware 10. The webcam drivers are working fine on the host machine (checked it while using the facebook video calling and google hangout), but doesn't seem to work on the guest Ubuntu machine. The webcam indicator light for my laptop is on when I use cheese, but no image or video is shown , just a black blank page.

webcam not working on Ubuntu vmware.

I also connected the Realtek_Integrated_Webcam_HD removable device from Vmware tools, still no luck.

5
  • Make sure video capabilty is enabled in your VM settings – George Udosen Dec 25 '16 at 11:28
  • @George where can I find that setting? – gr_aman Dec 25 '16 at 11:41
  • which is guest and which is host ? – George Udosen Dec 25 '16 at 13:13
  • Windows 10 is the host and Ubuntu 16.04 is the guest – gr_aman Dec 25 '16 at 14:05
  • What is the spec of your computer ? – George Udosen Dec 30 '16 at 22:08
3

Change USB Compatibility to 1.1 in Virtual Machine Settings.

VM Settings

1
  • This does not work for me. However, as @mmcc73 recommended, using USB3.0 works fine for me. – Tibor Takács Feb 28 '20 at 17:52
2

To get video capability in VMWare:

  1. Make sure your host system has video capabilities.
  2. Launch the vmware
  3. In the vmware look at the bottom (note: not in the guest system) and select connect to connect to host video device

enter image description here

  1. Note that VMWare will offer to disconnect the video device from the host please accept this. The video device should now work in the guest os.

NOTE: I tested this on -

  • Windows guest in Ubuntu host, and should work in yours.
  • Windows OS seems to act greedily when acquiring hardware on host and seems not to like to share (from my experience), so its possible that if your guest is Ubuntu then it may not offer to disconnect from host but if it does accept. That means the video device won't work on the host until you release it using the same steps as with connecting it.
  • In Virtualbox this is done when the guest has been stopped, while in VMWare it does this with the guest running as in your case.

Hope this helps.

3
  • The video device is successfully connected to the guest , but when I start cheese, it shows me a blank screen (black screen ) and the webcam indicator is on. (The webcam is on but I cannot see any picture of myself) – gr_aman Dec 25 '16 at 14:44
  • please restart the guest and add it again. – George Udosen Dec 25 '16 at 21:15
  • sorry for the late reply, but it is still not working – gr_aman Dec 26 '16 at 15:42
1

What worked for me was changing USB Compatibility from 2.0 to 3.0 in the VMWare settings for the linux guest.

0

What worked for me with Windows 10 and Ubuntu 18.04 on an HP2570p was to start camera in Windows 10 and then connect the VM settings to the camera. Note that "lsusb" did not list the camera device unless it was running in Windows 10 first. Also, the Windows camera app disconnects when the camera is running in Vmware and vice versa. Manual disconnection of camera device from VM was necessary to resume operation in Windows 10 without rebooting ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.