0

after installing Ubuntu 16.04 my new Laptop (Asus P2520LA) I can't solve a problem I have a with my wlan/internet, so I would be very thankful if you could help me.

The problem is, that after successfully connecting to my wlan, after some hours the internet drops out suddenly while I am just surfing on a website or something. The wlan connection to my router seems to stay intact but the internet is gone. (The "connected"-icon in the upper bar does not change but a ping is not possible).

After this, a wlan reconnect is not possible (via the icon) and the only possiblity I found to reconnect is rebooting or removing and adding my driver module:

sudo modprobe -r rtl8821ae && sudo modprobe rtl8821ae

In this thread a script was posted that collects relevant information for wlan problems, so here is the output of the script exectuted just after the internet connection has dropped:


########## wireless info START ##########

Report from: 24 Dec 2016 23:44 CET +0100

Booted last: 24 Dec 2016 00:00 CET +0100

Script from: 08 Jul 2016 02:16 UTC +0000

##### release ###########################

Distributor ID: Ubuntu
Description:    Ubuntu 16.04.1 LTS
Release:    16.04
Codename:   xenial

##### kernel ############################

Linux 4.4.0-57-generic #78-Ubuntu SMP Fri Dec 9 23:50:32 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=7

##### desktop ###########################

Ubuntu

##### lspci #############################

02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)
    Subsystem: ASUSTeK Computer Inc. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1043:205f]
    Kernel driver in use: r8169

03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter [10ec:8821]
    Subsystem: XAVi Technologies Corp. RTL8821AE 802.11ac PCIe Wireless Network Adapter [1b9a:2482]
    Kernel driver in use: rtl8821ae

##### lsusb #############################

Bus 001 Device 004: ID 138a:0010 Validity Sensors, Inc. VFS Fingerprint sensor
Bus 001 Device 003: ID b49a:04f2  
Bus 001 Device 002: ID 8087:8001 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 0bda:57b5 Realtek Semiconductor Corp. 
Bus 002 Device 004: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

##### rfkill ############################

2: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: asus-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
5: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
9: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

##### lsmod #############################

rtl8821ae             225280  0
btcoexist              53248  1 rtl8821ae
rtl_pci                28672  1 rtl8821ae
rtlwifi                77824  2 rtl_pci,rtl8821ae
mac80211              737280  3 rtl_pci,rtlwifi,rtl8821ae
cfg80211              565248  2 mac80211,rtlwifi
asus_nb_wmi            24576  0
asus_wmi               28672  1 asus_nb_wmi
sparse_keymap          16384  1 asus_wmi
wmi                    20480  1 asus_wmi
video                  40960  2 i915,asus_wmi

##### interfaces ########################

auto lo
iface lo inet loopback

##### ifconfig ##########################

enp2s0    Link encap:Ethernet  HWaddr   
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlp3s0    Link encap:Ethernet  HWaddr   
          inet addr:192.168.2.104  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::/64 Scope:Link
          inet6 addr: 2003:86:2f5d:995b:/64 Scope:Global
          inet6 addr: 2003:86:2f5d:995b:21de:9557:958c:f74a/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:759572 errors:0 dropped:0 overruns:0 frame:0
          TX packets:559030 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:854660727 (854.6 MB)  TX bytes:137790120 (137.7 MB)

##### iwconfig ##########################

enp2s0    no wireless extensions.

lo        no wireless extensions.

wlp3s0    IEEE 802.11abgn  ESSID:"WLAN-355254"  
          Mode:Managed  Frequency:5.2 GHz  Access Point:    
          Bit Rate=150 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=50/70  Signal level=-60 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:4275   Missed beacon:0

##### route #############################

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.2.1     0.0.0.0         UG    600    0        0 wlp3s0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlp3s0
192.168.2.0     0.0.0.0         255.255.255.0   U     600    0        0 wlp3s0

##### resolv.conf #######################

nameserver 127.0.1.1
search Speedport_W_921V_1_42_000

##### network managers ##################

Installed:

    NetworkManager

Running:

root       927     1  0 00:19 ?        00:00:10 /usr/sbin/NetworkManager --no-daemon

##### NetworkManager info ###############

GENERAL.DEVICE:                         wlp3s0
GENERAL.TYPE:                           wifi
GENERAL.NM-TYPE:                        NMDeviceWifi
GENERAL.VENDOR:                         Realtek Semiconductor Co., Ltd.
GENERAL.PRODUCT:                        RTL8821AE 802.11ac PCIe Wireless Network Adapter
GENERAL.DRIVER:                         rtl8821ae
GENERAL.DRIVER-VERSION:                 4.4.0-57-generic
GENERAL.FIRMWARE-VERSION:               N/A
GENERAL.HWADDR:                         
GENERAL.MTU:                            0
GENERAL.STATE:                          100 (connected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1c.3/0000:03:00.0/net/wlp3s0
GENERAL.IP-IFACE:                       wlp3s0
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     WLAN-355254
GENERAL.CON-UUID:                       048faba8-d463-4121-a601-8bea05ccdd93
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/4
GENERAL.METERED:                        no (guessed)
CAPABILITIES.CARRIER-DETECT:            no
CAPABILITIES.SPEED:                     150 Mb/s
CAPABILITIES.IS-SOFTWARE:               no
WIFI-PROPERTIES.WEP:                    yes
WIFI-PROPERTIES.WPA:                    yes
WIFI-PROPERTIES.WPA2:                   yes
WIFI-PROPERTIES.TKIP:                   yes
WIFI-PROPERTIES.CCMP:                   yes
WIFI-PROPERTIES.AP:                     yes
WIFI-PROPERTIES.ADHOC:                  yes
WIFI-PROPERTIES.2GHZ:                   yes
WIFI-PROPERTIES.5GHZ:                   yes
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/{6}
CONNECTIONS.AVAILABLE-CONNECTIONS[1]:   048faba8-d463-4121-a601-8bea05ccdd93 | WLAN-355254
IP4.ADDRESS[1]:                         192.168.2.104/24
IP4.GATEWAY:                            192.168.2.1
IP4.ROUTE[1]:                           dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000
IP4.DNS[1]:                             192.168.2.1
IP4.DOMAIN[1]:                          Speedport_W_921V_1_42_000
DHCP4.OPTION[1]:                        requested_routers = 1
DHCP4.OPTION[2]:                        requested_domain_search = 1
DHCP4.OPTION[3]:                        requested_time_offset = 1
DHCP4.OPTION[4]:                        requested_domain_name = 1
DHCP4.OPTION[5]:                        requested_rfc3442_classless_static_routes = 1
DHCP4.OPTION[6]:                        requested_broadcast_address = 1
DHCP4.OPTION[7]:                        requested_netbios_scope = 1
DHCP4.OPTION[8]:                        requested_wpad = 1
DHCP4.OPTION[9]:                        next_server = 192.168.2.1
DHCP4.OPTION[10]:                       expiry = 1484431469
DHCP4.OPTION[11]:                       requested_interface_mtu = 1
DHCP4.OPTION[12]:                       requested_subnet_mask = 1
DHCP4.OPTION[13]:                       routers = 192.168.2.1
DHCP4.OPTION[14]:                       dhcp_message_type = 5
DHCP4.OPTION[15]:                       ip_address = 192.168.2.104
DHCP4.OPTION[16]:                       requested_static_routes = 1
DHCP4.OPTION[17]:                       domain_name = Speedport_W_921V_1_42_000
DHCP4.OPTION[18]:                       requested_domain_name_servers = 1
DHCP4.OPTION[19]:                       broadcast_address = 192.168.2.255
DHCP4.OPTION[20]:                       requested_ntp_servers = 1
DHCP4.OPTION[21]:                       requested_netbios_name_servers = 1
DHCP4.OPTION[22]:                       dhcp_lease_time = 1814400
DHCP4.OPTION[23]:                       domain_name_servers = 192.168.2.1
DHCP4.OPTION[24]:                       requested_ms_classless_static_routes = 1
DHCP4.OPTION[25]:                       subnet_mask = 255.255.255.0
DHCP4.OPTION[26]:                       network_number = 192.168.2.0
DHCP4.OPTION[27]:                       requested_host_name = 1
DHCP4.OPTION[28]:                       dhcp_server_identifier = 192.168.2.1
IP6.ADDRESS[1]:                         2003:86:2f5d:995b:/64
IP6.ADDRESS[2]:                         2003:86:2f5d:995b:21de:9557:958c:f74a/64
IP6.ADDRESS[3]:                         fe80::/64
IP6.GATEWAY:                            fe80::1

GENERAL.DEVICE:                         enp2s0
GENERAL.TYPE:                           ethernet
GENERAL.NM-TYPE:                        NMDeviceEthernet
GENERAL.VENDOR:                         Realtek Semiconductor Co., Ltd.
GENERAL.PRODUCT:                        RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
GENERAL.DRIVER:                         r8169
GENERAL.DRIVER-VERSION:                 2.3LK-NAPI
GENERAL.FIRMWARE-VERSION:               
GENERAL.HWADDR:                         
GENERAL.MTU:                            1500
GENERAL.STATE:                          20 (unavailable)
GENERAL.REASON:                         2 (Device is now managed)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1c.2/0000:02:00.0/net/enp2s0
GENERAL.IP-IFACE:                       
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     --
GENERAL.CON-UUID:                       --
GENERAL.CON-PATH:                       --
GENERAL.METERED:                        unknown
CAPABILITIES.CARRIER-DETECT:            yes
CAPABILITIES.SPEED:                     unknown
CAPABILITIES.IS-SOFTWARE:               no
WIRED-PROPERTIES.CARRIER:               off
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: 

SSID         BSSID              MODE   CHAN  FREQ      RATE       SIGNAL  BARS  SECURITY   ACTIVE  * 
WLAN-355254    Infra  11    2462 MHz  54 Mbit/s  67      ▂▄▆_  WPA2       no        
WLAN-355254    Infra  40    5200 MHz  54 Mbit/s  60      ▂▄▆_  WPA2       yes     * 
Beethoven      Infra  1     2412 MHz  54 Mbit/s  54      ▂▄__  WPA1 WPA2  no        
Beethoven2     Infra  1     2412 MHz  54 Mbit/s  47      ▂▄__  WPA1 WPA2  no        
PoBaZ          Infra  1     2412 MHz  54 Mbit/s  40      ▂▄__  WPA1 WPA2  no        
DLAN           Infra  9     2452 MHz  54 Mbit/s  40      ▂▄__  WPA2       no        

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

##### NetworkManager.conf ###############

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

##### NetworkManager profiles ###########

[[/etc/NetworkManager/system-connections/WLAN-355254]] (600 root)
[connection] id=WLAN-355254 | type=wifi | permissions=user:rh:;
[wifi] mac-address= | mac-address-blacklist= | ssid=WLAN-355254
[ipv4] method=auto
[ipv6] method=ignore

[[/etc/NetworkManager/system-connections/eduroam-a]] (600 root)
[connection] id=eduroam-a | type=wifi | autoconnect=false | permissions=user:rh:;
[wifi] mac-address-blacklist= | ssid=eduroam-a
[802-1x] ca-cert=/home/rh/.cat_installer/ca.pem
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/YSR]] (600 root)
[connection] id=YSR | type=wifi | permissions=
[wifi] mac-address= | mac-address-blacklist= | ssid=YSR
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/iPhone rh]] (600 root)
[connection] id=iPhone rh | type=wifi | permissions=user:rh:;
[wifi] mac-address= | mac-address-blacklist= | ssid=iPhone rh
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/CIS]] (600 root)
[connection] id=CIS | type=wifi | permissions=user:rh:;
[wifi] mac-address= | mac-address-blacklist= | ssid=CIS
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/lrz]] (600 root)
[connection] id=lrz | type=wifi | permissions=user:rh:;
[wifi] mac-address= | mac-address-blacklist= | ssid=lrz
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/eduroam]] (600 root)
[connection] id=eduroam | type=wifi | permissions=user:rh:;
[wifi] mac-address-blacklist= | ssid=eduroam
[802-1x] ca-cert=/home/rh/.cat_installer/ca.pem
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/osm]] (600 root)
[connection] id=osm | type=wifi | permissions=user:rh:;
[wifi] mac-address= | mac-address-blacklist= | ssid=osm
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/Loch Ness]] (600 root)
[connection] id=Loch Ness | type=wifi | permissions=user:rh:;
[wifi] mac-address= | mac-address-blacklist= | ssid=Loch Ness
[ipv4] method=auto
[ipv6] method=auto

##### iw reg get ########################

Region: Europe/Berlin (based on set time zone)

country DE: DFS-ETSI
    (2400 - 2483 @ 40), (N/A, 20), (N/A)
    (5150 - 5250 @ 80), (N/A, 20), (N/A), NO-OUTDOOR
    (5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS
    (5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
    (57000 - 66000 @ 2160), (N/A, 40), (N/A)

##### iwlist channels ###################

enp2s0    no frequency information.

lo        no frequency information.

wlp3s0    32 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Channel 36 : 5.18 GHz
          Channel 40 : 5.2 GHz
          Channel 44 : 5.22 GHz
          Channel 48 : 5.24 GHz
          Channel 52 : 5.26 GHz
          Channel 56 : 5.28 GHz
          Channel 60 : 5.3 GHz
          Channel 64 : 5.32 GHz
          Channel 100 : 5.5 GHz
          Channel 104 : 5.52 GHz
          Channel 108 : 5.54 GHz
          Channel 112 : 5.56 GHz
          Channel 116 : 5.58 GHz
          Channel 120 : 5.6 GHz
          Channel 124 : 5.62 GHz
          Channel 128 : 5.64 GHz
          Channel 132 : 5.66 GHz
          Channel 136 : 5.68 GHz
          Channel 140 : 5.7 GHz
          Current Frequency:5.2 GHz (Channel 40)

##### iwlist scan #######################

wlp3s0    Interface doesn't support scanning : Device or resource busy

enp2s0    Interface doesn't support scanning.

lo        Interface doesn't support scanning.

##### module infos ######################

[rtl8821ae]
filename:       /lib/modules/4.4.0-57-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8821ae/rtl8821ae.ko
firmware:       rtlwifi/rtl8821aefw.bin
description:    Realtek 8821ae 802.11ac PCI wireless
license:        GPL
author:         Realtek WlanFAE 
srcversion:     B9E24DCC76240A48AEEF94E
depends:        rtlwifi,rtl_pci,btcoexist,mac80211
intree:         Y
vermagic:       4.4.0-57-generic SMP mod_unload modversions 
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           msi:Set to 1 to use MSI interrupts mode (default 1)
 (bool)
parm:           debug:Set debug level (0-5) (default 0) (int)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)
parm:           int_clear:Set to 0 to disable interrupt clear before set (default 1)
 (bool)

[rtl_pci]
filename:       /lib/modules/4.4.0-57-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl_pci.ko
description:    PCI basic driver for rtlwifi
license:        GPL
author:         Larry Finger    
author:         Realtek WlanFAE 
author:         lizhaoming  
srcversion:     A96EBF28EBD4603749D5EC3
depends:        mac80211,rtlwifi
intree:         Y
vermagic:       4.4.0-57-generic SMP mod_unload modversions 

[rtlwifi]
filename:       /lib/modules/4.4.0-57-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtlwifi.ko
description:    Realtek 802.11n PCI wireless core
license:        GPL
author:         Larry Finger    
author:         Realtek WlanFAE 
author:         lizhaoming  
srcversion:     81DBE78DD4871E3EC5F2E9D
depends:        mac80211,cfg80211
intree:         Y
vermagic:       4.4.0-57-generic SMP mod_unload modversions 

[mac80211]
filename:       /lib/modules/4.4.0-57-generic/kernel/net/mac80211/mac80211.ko
license:        GPL
description:    IEEE 802.11 subsystem
srcversion:     0B114888238BEBBE8043BC5
depends:        cfg80211
intree:         Y
vermagic:       4.4.0-57-generic SMP mod_unload modversions 
parm:           minstrel_vht_only:Use only VHT rates when VHT is supported by sta. (bool)
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211]
filename:       /lib/modules/4.4.0-57-generic/kernel/net/wireless/cfg80211.ko
description:    wireless configuration support
license:        GPL
author:         Johannes Berg
srcversion:     FD4B9DA2F385F0531B5CB0B
depends:        
intree:         Y
vermagic:       4.4.0-57-generic SMP mod_unload modversions 
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

##### module parameters #################

[rtl8821ae]
debug: 0
disable_watchdog: N
fwlps: Y
int_clear: Y
ips: Y
msi: Y
swenc: N
swlps: N

[mac80211]
beacon_loss_count: 7
ieee80211_default_rc_algo: minstrel_ht
max_nullfunc_tries: 2
max_probe_tries: 5
minstrel_vht_only: Y
probe_wait_ms: 500

[cfg80211]
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

##### modprobe options ##################

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/intel-microcode-blacklist.conf]
blacklist microcode

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

[/etc/modprobe.d/mlx4.conf]
softdep mlx4_core post: mlx4_en

##### rc.local ##########################

exit 0

##### pm-utils ##########################

##### udev rules ########################

##### dmesg #############################

[36761.451466] rtlwifi: rtlwifi: wireless switch is on
[36761.467119] r8169 0000:02:00.0 enp2s0: link down
[36764.042342] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready
[36764.055231] r8169 0000:02:00.0 enp2s0: link down
[36764.055295] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready
[36764.056451] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready (repeated 3 times)
[36785.135515] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready
[36785.149084] r8169 0000:02:00.0 enp2s0: link down
[36785.149272] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready
[36785.150256] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready (repeated 3 times)
[36818.799890] wlp3s0: authenticate with 
[36818.800332] wlp3s0: send auth to  (try 1/3)
[36818.801023] wlp3s0: authenticated
[36818.802169] wlp3s0: associate with  (try 1/3)
[36818.803012] wlp3s0: RX AssocResp from  (capab=0x11 status=0 aid=5)
[36818.807968] wlp3s0: associated
[36818.807985] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready

########## wireless info END ############

There is another odd thing I noticed that might be relevant: After the internet has dropped out, I can disconnect from the wlan via the icon but I can't reconnect. But after executing the analysis-script, the reconnections works just fine.

I would be very happy if you could help me with this problem. If you need any other information, tell me and I will post it.

Thanks!

EDIT: After some more searching, I found some posts/articles that describe exactly the same problem as I have:

Wireless disconnect issues Ubuntu 16.04 with RTL8821ae

https://medium.com/@elmaxx/rtl8821ae-wifi-drivers-in-ubuntu-16-04-4c1286524afa#.dsczz2t2w

https://ubuntuforums.org/showthread.php?t=2245164

Unfortunately, in some posts the problem stays unsolved and in some others, where solutions are posted, the solutions don't work for me, so I really count on your help.

  • 1
    I believe the correct command is: sudo service network-manager restart – chili555 Dec 25 '16 at 0:36
  • okay, I'll try this next time. But why is this better than the modprobe command I have posted? – Raphael Dec 25 '16 at 15:08
  • Okay, after the internet drops out, I can reconnect after executing your command. So I can use this command to restart the network-manager instead of removing and adding my driver module. Anyway, I'd like to find a way to fix the issue, so the internet stops dropping out randomly. – Raphael Dec 25 '16 at 16:26
  • Please try this and let us know: askubuntu.com/questions/748113/wifi-still-sleeping-when-resume/… – chili555 Dec 25 '16 at 17:32
  • Okay, I followed the instructions in that thread. But I don't know yet if the issue is fixed. (My problem is not related to hybernating the laptop and I can't reproduce the internet drop as it occurs (seemingly) randomly). I will tell you tomorrow if the error has occured. – Raphael Dec 25 '16 at 18:21
1

So I think I fixed the problem now. If the dropout does not occur within the next days, I'll mark this thread as solved.

I tried multiple strategies that have been posted on different sites. Maybe it would just be enough to install new drivers ( -> paragraph 5), but I'll list up everything in did, just in case there might be dependencies:

1. Ignore IPv6

(No direct success)

source: https://ubuntuforums.org/showthread.php?t=2288456

Click on Network Manager -> Click 'Edit' -> Edit the wireless connection -> Click the IPv6 tab -> Set IPv6 to ignore -> click OK -> Reboot.

2. Edit wifi-resume.service

(No direct success)

source: wifi still sleeping when resume

gksudo gedit  /etc/systemd/system/wifi-resume.service

Add the following:

[Unit]
Description=Local system resume actions
After=suspend.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target

close the text editor.

Now do:

sudo chmod +x  /etc/systemd/system/wifi-resume.service
sudo systemctl enable wifi-resume.service

reboot

3. Configurate Driver

(No direct success)

source: 16.04 LTS wifi connection lost randomly every 5 minutes

  1. Get details of your PCI wireless card by running sudo lshw -class network
  2. Get your card model info according to the product line. For instance, as you can see in the question description it says product: RTL8723BE PCIe Wireless Network Adapter so the model of my card is RTL8723BE
  3. Open or create /etc/pm/config.d/config and add SUSPEND_MODULES="rtl8723be"(replace rtl8723be with your own model number) Then run echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf and reboot.

Now your system should be able to reconnect automatically after sleep, and wifi connection never got lost once for me after doing this.

4. Install other drivers

(No direct success)

Source: https://medium.com/@elmaxx/rtl8821ae-wifi-drivers-in-ubuntu-16-04-4c1286524afa#.dsczz2t2w

Check, if your card is one of the following models: rtl8192ce, rtl8192se, rtl8192de, rtl8188ee, rtl8192ee, rtl8723ae, rtl8723be, and rtl8821ae

lspci | grep Wireless

Then:

sudo apt-get install linux-headers-generic build-essential git 
git clone http://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
make
sudo make install
sudo modprobe rtl8821ae

Reboot.

5. Again, install different drivers

(Success!?)

Source: Dropping Internet connection on Realtek Semiconductor Co., Ltd. RTL8821AE

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt update
sudo apt install rtlwifi-new-dkms
1

Ive been through all this after upgrade to 16.04 wi fi dropping after 5 minutes and then very slow

Then did this dis conected wifi

Attached router via ethernet.

Opened terminal

entered in terminal sudo apt-get install wicd

Then entered wicd in search, dragged icon to side bar clicked on icon and followed prompts.

Have used used channel 11 on router

Have had no problems for last 6 hours and speed increased,have rebooted 3 times just to check connecting automatically seems OK

0
sudo service network-manager restart

This command should fix it mate(You should repeat it when ever your connection drops).I am no expert but an advice,if your laptop is old try checking if the card is over heating or the next time it disconnects don't run the command,restart the router and check if it is connecting,if it does it is the problem of the router not your Computer/OS.I used to have this problem,my computer won't connect to the network restarting the router fixed it.

  • Yes, I already know this command as it was posted by chili555. Anyway, I'd like to find a way to fix the issue, so the internet stops dropping out randomly – Raphael Dec 26 '16 at 14:44
  • Also it is not a router issue, I have tested it on multiple different wlan networks and my problem occured in every one of them – Raphael Dec 26 '16 at 14:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.