1

I want to install MariaDB 10.1 on a fresh 16.04 server installation but I keep getting this error:

The following packages have unmet dependencies:
mariadb-server : Depends: mariadb-server-10.1 (= 10.1.20+maria-1~xenial) but it is not installable
E: Unable to correct problems, you have held broken packages.

I have already tried reinstalling Ubuntu as well as pinning the repository but it didn't help at all. I am using the installation instructions from the official website.

  • please post the link to the official website – George Udosen Dec 24 '16 at 21:39
0

Would any of this help?

https://downloads.mariadb.org/
https://downloads.mariadb.org/mariadb/10.1.20/

For Ubuntu, here is a better link. Might be safe to skip #mirror=...

https://downloads.mariadb.org/mariadb/repositories/#mirror=jaleco

I haven't succeeded in solving this one yet.
(See Ubuntu 16.04 MariaDB 10.1 installation in Retrograde :D)

  • If you get to a point where you want to tarball the mysql directories, clean up everything and re-install, this is working so far as the installation. See, in askubuntu. Now if anyone has tips on getting the database back from the tarball, I'd appreciate it. – Nobody Jan 8 '17 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.