1

Added after solution - This is NOT a dual boot issue!

This was a driver issue as the open source drivers for what ever reason didn't work with my NVIDIA GTX 960m and full disk encryption. They did how ever work perfectly well without encryption, which is at least to my uneducated mind, somewhat strange. Leaving rest of the post intact.

Description

I'm having a very strange problem with dual-booting W10 and Xenial with "FDE"(?) on the Xenial partition. After I type in my FDE password it says "cryptsetup successful", and hangs-stalls-locks-freezes under certain conditions.

If I type in my password to slow it hangs, I have about 3 seconds to type in my password otherwise it will hang on cryptsetup successful. This means I can only have very simple passwords. If I manage to type in the password within those 3 seconds, Ubuntu boots normal the way it should. If I boot into recovery mode, I can type in the password as slow as I want but then some drivers (GFX?) will not be loaded.

My installation process (according to: https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1514120/comments/2)

  1. W10 was already installed.
  2. Shrunk volume so I could install Xenial.
  3. Boot into install, choose "Something else" so I can manage my volumes myself.
  4. Make 1 GB part for /boot, rest for /root with LVM + LUKS, boot loader over the windows boot loader (but I've also tried putting it on /boot)
  5. Install, with and without updates, with and without prop. drivers.

Console output

Info I get when it freezes. The first error, "nouveau" also appears when I actually manage to boot (with fast and slow pass). The image (that I can't post) is below

s30.postimg.org/46i6j3y1t/20161224_185703.jpg

I've tried

  1. trustdarkness.com/wordpress/ubuntuxubuntu-boot-hangs-after-cryptsetup-successful/
    • No lxc-android-config
  2. ubuntu-mate.community/t/using-cryptsetup-hangs/6537/2
    • Doesn't work for me, but I got cryptsetup v: 2:1.7.2-0ubuntu1
  3. A lot of trail and error, that didn't yield anything but knowing that when I type in the password fast in < 3 secs it boots.

Additional info

  1. I can decrypt, mount and write to the drive from the install USB.
  2. My setups is an Asus ZenBook Pro UX501VW (16GB Ram + tocuh if that matters.)
  3. Windows obviously boots without a problem
  4. Out of 35 boots, it managed to boot twice when I typed the password in slowly. I recorded the tests but I could not reproduce the results.

I'm very new to Ubuntu/Linux so I wanted to install it to learn more and get used to it. Sorry if the info is too much, but I tend to think too much is better than too little when you don't know what you are dealing with.

Thanks in advance.

I'll update the post with new things I've tried if I get any suggestions.

Changes

12/24 - Added console output and some additional info. 12/25 - Added clarification to the original post as to explain what the issue really was, not what it appeared to be to me. Hopefully it will help people with a similar problem.

  • I've fully now without dual boot. So now its just Ubuntu with FDE and it still doesn't work, so this is obviously not a dual boot issue. I'll keep searching, but now I'm leaning towards FDE with veracrypt(Win + Ubuntu), though its far from as safe. – elmak Dec 24 '16 at 21:50
0

Feels utterly stupid to answer my own question but in case anyone bumps into this problem in the future, at least here it is (or was for me).

So the problem is NOT dual boot, but rather a general problem that cryptsetup hangs the system after typing in the password to slow (fast worked at least for me), with a "cryptsetup successful" message. The issue for me seemed to have been the NVIDIA drivers on my GTX 960m, so I suspect that there might be more people like me with a similar issue.

To fix this, boot into recovery and install proprietary drivers for the GFX and then reboot and it should work. For what ever reason it didn't work doing this for me at install time, I've tried, but that might have been something else with my setup.

Anyways, sorry for the clutter. If I could have pinned down the problem more accurately in the begging this info could have been useful to some googlers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.