1

I've got a Dell Latitude E5570 with Ubuntu 14 LTS preinstalled with some dell software.

Knowing that there is a new LTS out there my first thing was to run sudo apt-get update and it failed with Unable to connect to dell.archive.canonical.com:http: and Failed to fetch ....

Pinged dell.archive.canonical.com without success, so tried it using Google's and OpenDNS's nameservers but no success. If you already read it until here, please comment if you can get a ping response. Pinging only archive.canonical.com works, so... I don't know.

Is there a policy change since my laptop was preinstalled that I should fix now? Is it a temporal issue? Is it normal and I should just get along with this issue removing the dell update sources?... hope not... I would expect more from Dell/Canonical.

Would like to have Dell's dedicated software and proceed in the recommended way by Dell/Canonical.

This is the output in reply to my update request:

Err http://dell.archive.canonical.com trusty-dell-biz-vivid-skl InRelease      

Err http://dell.archive.canonical.com trusty-dell InRelease                    

Err http://dell.archive.canonical.com trusty-dell-biz-vivid-skl Release.gpg
  Unable to connect to dell.archive.canonical.com:http:
Err http://dell.archive.canonical.com trusty-dell Release.gpg
  Unable to connect to dell.archive.canonical.com:http:
Err http://oem.archive.canonical.com trusty-oem-sp1 InRelease

Err http://oem.archive.canonical.com trusty-oem InRelease  

Err http://oem.archive.canonical.com trusty-oem-sp1 Release.gpg
  Unable to connect to oem.archive.canonical.com:http:
Err http://oem.archive.canonical.com trusty-oem Release.gpg
  Unable to connect to oem.archive.canonical.com:http:
Reading package lists... Done
W: Failed to fetch http://dell.archive.canonical.com/updates/dists/trusty-dell-biz-vivid-skl/InRelease  

W: Failed to fetch http://dell.archive.canonical.com/updates/dists/trusty-dell/InRelease  

W: Failed to fetch http://oem.archive.canonical.com/updates/dists/trusty-oem-sp1/InRelease  

W: Failed to fetch http://oem.archive.canonical.com/updates/dists/trusty-oem/InRelease  

W: Failed to fetch http://dell.archive.canonical.com/updates/dists/trusty-dell-biz-vivid-skl/Release.gpg  Unable to connect to dell.archive.canonical.com:http:

W: Failed to fetch http://dell.archive.canonical.com/updates/dists/trusty-dell/Release.gpg  Unable to connect to dell.archive.canonical.com:http:

W: Failed to fetch http://oem.archive.canonical.com/updates/dists/trusty-oem-sp1/Release.gpg  Unable to connect to oem.archive.canonical.com:http:

W: Failed to fetch http://oem.archive.canonical.com/updates/dists/trusty-oem/Release.gpg  Unable to connect to oem.archive.canonical.com:http:

W: Some index files failed to download. They have been ignored, or old ones used instead.
  • I think the Dell's PPA is no longer needed since the patches have been merged to the mainline kernel. You may have noticed the change when you upgrade to 14.04.5, the last point release that also upgrades the kernel series. – user589808 Dec 23 '16 at 18:37
  • 1
    So dell.archive.canonical is dead because the ppa is no longer needed, all the dell specific things are supported from the kernel? Please point this out from some official sources in an answer. And I guess your recommendation is to remove these broken PPAs. the oem.archive.canonical.com ones as well? – obeliksz Dec 23 '16 at 18:52
  • I don't know specifics about Dell hardware but all the PPAs named "Dell" go as far as 14.04 only. So it stands to reason they're no longer needed and/or maintained. Either way they don't work and you should check each and every one to make sure and remove them accordingly. – user589808 Dec 23 '16 at 18:56
  • 1
    would be good to read a blog post/article on this on how others proceeded with these PPAs... it guess I'm not the pioneer with this issue, although I couldn't find an answer in my searchings... – obeliksz Dec 23 '16 at 20:13
  • 1
    Have you tried contacting Dell? – ben rudgers Dec 29 '16 at 17:41
1

Those repositories are still available. They were just down for a day or two due to a drive failure.

0

Any kind of update attempt failed because canonical's dell repo was down for at least 3 days. As the repo was down, I disabled the PPAs that were not available(oem.archive.canonical.com, dell.archive.canonical.com) but you should skip this as they should be available by now.

Dell's PPA is not strictly neccessary since the patches have been merged to the mainline kernel. Furthermore Dell doesn't provide it's preinstalled ISO publicly for this model, but only recommends to install the default Ubuntu image.

While doing the sudo apt-get upgrade I got into a Configure Secure Boot dialog, where I went forward and left the Disable UEFI Secure Bott option checked. Entered a password. I didn't restart yet, choose Restart later.

Seems like there is a bug in the Software & Updates as it didn't save my setting to notify me on LTS upgrade. To do it by terminal type sudo sed -i 's/=never/=lts/g' /etc/update-manager/release-upgrades

Double check that you got all the current upgrades: sudo apt-get upgrade I got some packages that were automatically installed and are no longer required, so did sudo apt-get autoremove.

Now do the release upgrade: sudo do-release-upgrade Continue, continue, continue...

At boot time in Bios appeared a dialog for this one time only, choose continue booting.

The additional Dell GUI tools remained intact and are working fine:

Dell Driver installer
Dell Recovery

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.