19

I'm trying to use my bluetooth headset (Bluedio, in the screenshot) in Ubuntu-Gnome 16.10, but I keep getting a horrible sound quality in everything.

Important note: I've just tested with a different device, a bluetooth speaker, and it gets the A2DP profile automatically, with a nice sound quality. The problem, then, is only happening with my bluetooth headset.

I've read some posts and the given suggestions don't work in my case (Ubuntu-Gnome 16.10). These suggestions are:

1) Under the Sound settings, change the headset profile to the A2DP (High Fidelity Playback). Not only the sound quality didn't even change, the profile keeps getting turned back to Headset Head Unit (HSP/HFP) profile, in which the sound quality remains horrible. So, even though the A2DP profile shows up there, it doesn't take effect and goes back to the HSP/HFP profile everytime.

2) Changes in the /etc/bluetooth/audio.conf file, like uncommenting the line "AutoConnect=true line". First of all, there isn't such file in Ubuntu-Gnome 16.10. Instead, there is the /etc/bluetooth/main.conf file, which seems pretty similar to the first one in terms of parameters. But, the line is already uncommented in my S.O., just as the suggestion tells me to do. So, it seems that there's nothing to do here with this suggestion.

Here's the screenshot of the Sound Settings' screen. You can see that there's an arrow for the dropdown list, where the A2DP profile shows up (even though it's not appearing in the shot. It's there though), but it gets back to the HSP/HFP profile everytime.

Here's the link for the screenshot:

picture 1

  • See this related question. – Mike Pierce Jul 23 '17 at 15:33
  • sometimes you might forgot about the output volume when selecting High fidelity playback – Kalanka Mar 30 at 5:19
19

I've managed to fix it. Even though I'm not sure if the following steps are in the exactly order to do it, I'm pretty sure it was the combination of them that fixed it. Here they are:

  1. I've installed Blueman: sudo apt-get install blueman

  2. I've edited the /etc/bluetooth/audio.conf file: sudo -H gedit /etc/bluetooth/audio.conf and add this line in the end of it: Disable=Headset. Users on Ubuntu 17.04 and above may not have audio.conf, but can instead use main.conf.

Note: I've also installed something called "pavucontrol" via terminal with the command sudo apt-get install pavucontrol, but I'm really not sure if it was this or the Blueman that solved it. I suspect it was the Blueman, but if it doesn't help, try the pavucontrol and see if it solves.

Hope this helps!

  • 4
    Yeah, adding that line Disable=Headset did it for me. :D And pavucontrol is PulseAudio Volume Control, so I don't think installing that was necessary to fix the problem. – Mike Pierce Jul 23 '17 at 15:31
  • I have just tested the step 1 and 2. Re-connected the bluetooth headset and it worked for me. So no need for pavucontrol. – Murat Gürsu Nov 12 '17 at 15:55
  • Here Here!! Worked for me too. Only needed blueman on Ubuntu 17.04. Then I edited main.conf and restarted bluetooth from the top panel icon. After that I selected high fidelity and now it works. Nice writeup - Thanks! – Ole Dec 13 '17 at 0:24
  • Disable=Headset worked for me, but I also had to do sudo service bluetooth restart for it to work. And the question remains: Why does it work? – BlueBomber May 30 '18 at 17:49
  • 1
    To clarify: after doing this, will I still be able to use the headset as, well, a headset? I'm asking because I see three audio profiles in pavucontrol and blueman-applet: headset, high-fidelity sink, high-fidelity source. Selecting high-fidelity sink in pavucontrol (the default in 18.04) results in no audio source from the headset appearing at all. – Raphael Jun 12 at 16:14
3

I also had the same problem with automatic change back to HSP/HFP.

I solved this by editing /etc/bluetooth/main.conf and uncommenting the line

Name = BlueZ

in the section [General].

Though, it might be not available, when the bluez package is not installed.

Thanks anyway for the tip with the file.

  • I had to uncomment this line as well to get mine to work. Thanks. – rayryeng Apr 7 at 8:37
  • worked in 18.04 – cipricus Jun 4 at 18:42
  • I first thought this fixed it, but unfortunately every time I reconnect, the headphones are back on HSP/HFP instead of A2DP. :( – Murch Aug 13 at 22:24
2
  1. Install Blueman:

    sudo apt-get install blueman
    
  2. Add Disable=headset to /etc/bluetooth/main.conf.

  3. Restart the bluetooth daemon:

    sudo service bluetooth restart
    

If you still have poor sound quality go to pavucontrol and under Configuration set the profile of your device to off and then to A2DP and it should work now.

  • Works like a charm in Linux Mint 19! Thanks :) – develCuy Sep 15 '18 at 17:08
1

Thanks for the info, worked great!

On Ubuntu 17.10 I had to change:

Settings > sound > output tab Select Bluetooth output Then set profile to 'high fidelity playback (a2dp sink)

1

Get the index of your card:

pacmd list-cards

Set the cards profile to a2dp (example: index 2):

pacmd set-card-profile 2 a2dp_sink

Credit to develmusa of the ArchLinux forums: https://bbs.archlinux.org/viewtopic.php?pid=1720877#p1720877

protected by Community Nov 27 '18 at 1:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.