Just installed xubuntu 16 on my HP 630, when I firstly selected xubuntu on boot it worked, but after turning off, and then on, it now stucks at "dev sda2 clean, XXX files, YYY blocks". I waited a lot but seems like it just won't boot as nothing changes at all. Btw I have the same message on other HP Pavilion 15, but it only appears for 2 seconds. What can I do with this.

Setting " nomodeset" in grub's ubuntu entry didn't worked, all the same, but with lower screen resolution.

Summary : hp 630; dualboot with win7; xubuntu 16.04 with ext4 and 32bit.

  • Pls help me someone D: – Ni Xt Dec 23 '16 at 13:03

It is doing a check of your disks. Depending on the size of your hard drives, this could take an extraordinarily long amount of time.

You can edit the sixth field in /etc/fstab for each filesystem to be mounted on boot to determine whether it does a filesystem check by changing it to 0.


How to skip boot-time fsck check preferably by editing grub menu-entry?

Editing /etc/fstab file to bypass fsck check at boot:

You can change the value of , the 6th field of file system description line in /etc/fstab to 0 (zero) to avoid filesystem check at the boot. (For your swap it's already 0, so you'll have to change your / and /home partitions' values from 1 and 2 respectively to 0 each.)


UUID=0a0fda6a-a0af-461f-936e-fe6feff3adba /      ext2  errors=remount-ro 0       1

UUID=b9ed5358-a68a-48ef-8c51-7241f0462913 /home  ext4  defaults          0       2

UUID=301dcfce-1bb3-415d-a71a-df64add29443 none   swap    sw              0       0
..so that the entries look like:


UUID=0a0fda6a-a0af-461f-936e-fe6feff3adba /      ext2  errors=remount-ro 0       0

UUID=b9ed5358-a68a-48ef-8c51-7241f0462913 /home  ext4  defaults          0       0

UUID=301dcfce-1bb3-415d-a71a-df64add29443 none   swap    sw              0       0
The documented description of the fs_passno i.e.  field in /etc/fstab file:

The sixth field (`fs_passno`):
This field is used by the fsck program to determine the order in which filesystem checks are done at reboot time. The root filesystem should be specified with a fs_passno of 1, and other filesystems should have a fs_passno of 2. Filesystems within a drive will be checked sequentially, but filesystems on different drives will be checked at the same time to utilize parallelism available in the hardware. If the sixth field is not present or zero, a value of zero is returned and fsck will assume that the filesystem does not need to be checked.
  • Thx, I've done this, but.. problem is still exists. It's still shows the same line. – Ni Xt Dec 25 '16 at 11:49
  • Could you post the exact line, either take a pic or copy paste please? – Kyle H Dec 25 '16 at 12:18
  • sorry I already reinstalled xubuntu as I needed to do some work on that laptop at the moment. – Ni Xt Dec 28 '16 at 11:39
  • No problem. Please post again if you run into the issue again – Kyle H Dec 28 '16 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.