I do have Ubuntu 16.04 running on Dell 13 5368 2-in-1 with touchscreen but it doesn't work.

xinput:

    ⎡ Virtual core pointer                      id=2    [master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
    ⎜   ↳ Logitech T400                             id=10   [slave  pointer  (2)]
    ⎜   ↳ DELL073B:00 06CB:7E7E Touchpad            id=11   [slave  pointer  (2)]
    ⎜   ↳ SynPS/2 Synaptics TouchPad                id=15   [slave  pointer  (2)]
    ⎜   ↳ Raydium Corporation Raydium Touch System  id=18   [slave  pointer  (2)]
    ⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
        ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
        ↳ Power Button                              id=6    [slave  keyboard (3)]
        ↳ Video Bus                                 id=7    [slave  keyboard (3)]
        ↳ Power Button                              id=8    [slave  keyboard (3)]
        ↳ Sleep Button                              id=9    [slave  keyboard (3)]
        ↳ Intel Virtual Button driver               id=12   [slave  keyboard (3)]
        ↳ Intel HID events                          id=13   [slave  keyboard (3)]
        ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]
        ↳ Dell WMI hotkeys                          id=16   [slave  keyboard (3)]
        ↳ Logitech T400                             id=17   [slave  keyboard (3)]
        ↳ Integrated_Webcam_HD                      id=19   [slave  keyboard (3)]

xinput list-props:

Device 'Raydium Corporation Raydium Touch System':
    Device Enabled (139):   1
    Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Calibration Matrix (315):  1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Calibration Matrix Default (316):  1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Send Events Modes Available (260): 1, 0
    libinput Send Events Mode Enabled (261):    0, 0
    libinput Send Events Mode Enabled Default (262):    0, 0
    Device Node (263):  "/dev/input/event11"
    Device Product ID (264):    9094, 12561
    libinput Horizonal Scroll Enabled (265):    0

/usr/share/X11/xorg.conf.d/90-libinput.conf:

# Match on all types of devices but tablet devices and joysticks
Section "InputClass"
        Identifier "libinput pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
    Option "Tapping" "on"
EndSection

Section "InputClass"
        Identifier "libinput touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

grep -e "Using input driver 'libinput'" /var/log/Xorg.0.log

[     3.968] (II) Using input driver 'libinput' for 'Power Button'
[     4.000] (II) Using input driver 'libinput' for 'Video Bus'
[     4.013] (II) Using input driver 'libinput' for 'Power Button'
[     4.033] (II) Using input driver 'libinput' for 'Sleep Button'
[     4.045] (II) Using input driver 'libinput' for 'Logitech T400'
[     4.061] (II) Using input driver 'libinput' for 'DELL073B:00 06CB:7E7E Touchpad'
[     4.091] (II) Using input driver 'libinput' for 'Intel Virtual Button driver'
[     4.106] (II) Using input driver 'libinput' for 'Intel HID events'
[     4.124] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'
[     4.153] (II) Using input driver 'libinput' for 'SynPS/2 Synaptics TouchPad'
[     4.178] (II) Using input driver 'libinput' for 'Dell WMI hotkeys'
[     4.194] (II) Using input driver 'libinput' for 'Logitech T400'
[     4.198] (II) Using input driver 'libinput' for 'Raydium Corporation Raydium Touch System'
[     4.344] (II) Using input driver 'libinput' for 'Integrated_Webcam_HD'

It seems that device is enabled, xinput driver loaded but it doesn't work. Couldn't get any events from device. Any ideas?

First verify, that cat /dev/input/event11 and touching screen will give you some data on terminal. In case is does, device and kernel driver works properly.

Another thing, check if your user is in "input" group. For me everything except TS worked well, even without my user being in input group.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.