1

Installation of newest AMD drivers fails

I tried the steps provided on the above link since it is the closest to the steps provided by AMD in installation instructions and i am still not able to install AMD proprietary driver.

I have a dual Intel/Amd graphics on board

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) 
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series] (rev ff)

I downloaded the following packages from AMD website

$ ls
fglrx_15.201-0ubuntu1_amd64_UB_14.01.deb
fglrx-amdcccle_15.201-0ubuntu1_amd64_UB_14.01.deb
fglrx-core_15.201-0ubuntu1_amd64_UB_14.01.deb
fglrx-dev_15.201-0ubuntu1_amd64_UB_14.01.deb

Then i followed the following steps

Enable support for 32bit packages if you have a 64bit OS -

sudo dpkg --add-architecture i386

Install the following packages -

sudo apt-get install lib32gcc1 libc6-i386

$ sudo apt-get install lib32gcc1 libc6-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  lib32gcc1 libc6-i386
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 2,249 kB of archives.
After this operation, 10.0 MB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libc6-i386 amd64 2.19-0ubuntu6.9 [2,201 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ trusty-updates/main lib32gcc1 amd64 1:4.9.3-0ubuntu4 [47.8 kB]
Fetched 2,249 kB in 24s (90.7 kB/s)                                            
Selecting previously unselected package libc6-i386.
(Reading database ... 201513 files and directories currently installed.)
Preparing to unpack .../libc6-i386_2.19-0ubuntu6.9_amd64.deb ...
Unpacking libc6-i386 (2.19-0ubuntu6.9) ...
Selecting previously unselected package lib32gcc1.
Preparing to unpack .../lib32gcc1_1%3a4.9.3-0ubuntu4_amd64.deb ...
Unpacking lib32gcc1 (1:4.9.3-0ubuntu4) ...
Setting up libc6-i386 (2.19-0ubuntu6.9) ...
Setting up lib32gcc1 (1:4.9.3-0ubuntu4) ...
Processing triggers for libc-bin (2.19-0ubuntu6.9) ...

Then i tried installing the files by using

sudo dpkg -i *.deb

and got the following error

sudo dpkg -i *.deb
Selecting previously unselected package fglrx.
dpkg: regarding fglrx_15.201-0ubuntu1_amd64_UB_14.01.deb containing fglrx:
 xserver-xorg-core-lts-xenial conflicts with fglrx
  fglrx (version 2:15.201-0ubuntu1) is to be installed.

dpkg: error processing archive fglrx_15.201-0ubuntu1_amd64_UB_14.01.deb (--install):
 conflicting packages - not installing fglrx
Selecting previously unselected package fglrx-amdcccle.
(Reading database ... 201822 files and directories currently installed.)
Preparing to unpack fglrx-amdcccle_15.201-0ubuntu1_amd64_UB_14.01.deb ...
Unpacking fglrx-amdcccle (2:15.201-0ubuntu1) ...
Selecting previously unselected package fglrx-core.
dpkg: regarding fglrx-core_15.201-0ubuntu1_amd64_UB_14.01.deb containing fglrx-core:
 xserver-xorg-core-lts-xenial conflicts with fglrx-core
  fglrx-core (version 2:15.201-0ubuntu1) is to be installed.

dpkg: error processing archive fglrx-core_15.201-0ubuntu1_amd64_UB_14.01.deb (--install):
 conflicting packages - not installing fglrx-core
Selecting previously unselected package fglrx-dev.
Preparing to unpack fglrx-dev_15.201-0ubuntu1_amd64_UB_14.01.deb ...
Unpacking fglrx-dev (2:15.201-0ubuntu1) ...
dpkg: dependency problems prevent configuration of fglrx-amdcccle:
 fglrx-amdcccle depends on fglrx; however:
  Package fglrx is not installed.

dpkg: error processing package fglrx-amdcccle (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of fglrx-dev:
 fglrx-dev depends on fglrx-core | fglrx; however:
  Package fglrx-core is not installed.
  Package fglrx is not installed.

dpkg: error processing package fglrx-dev (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 fglrx_15.201-0ubuntu1_amd64_UB_14.01.deb
 fglrx-core_15.201-0ubuntu1_amd64_UB_14.01.deb
 fglrx-amdcccle
 fglrx-dev
1

You are using 14.04.5, which includes the HWE kernel and Xorg packages that are backported from 16.04 LTS. These are incompatible with the fglrx driver. You need to downgrade to 14.04.4 or earlier kernel and Xorg, if you wish to use fglrx.

You can either re-install, or install the kernel and Xorg packages manually by installing the versions which have -lts-utopic appended to the package names.

  • Can you please tell me exactly how do i downgrade to 14.04.4 or install the kernel and Xorg packages manually? I am a newbie to linux and have no idea about using terminals and commands – Frostking Dec 22 '16 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.