UBUNTU is stuck at the loading menu when I rebooted after disabling the display manager using the command:

sudo systemctl disable display-manager.service

I used the answer here to disable the display-manager: https://superuser.com/questions/1088054/how-to-boot-to-command-line-interface-in-ubuntu-16-04

Now the answer suggests that if you run into any trouble, add nomodeset into your kernel parameters. When I press escape for GRUB at boot, I get GRUB shell. How do I add nomodeset to the kernel parameters from GRUB shell?

1 Answer 1


When booting, at the grub screen press 'e' with the default entry selected to edit the grub config for that kernel. Go to the line starting with 'kernel' and usually 'quiet splash' towards the end of it. Go to the end of this line, and add 'nomodeset'. Press F10 to boot and see if it helps!

  • I don't seem to get the option to select the entries as when I press SHIFT, I get to GRUB2 shell Dec 22, 2016 at 14:15
  • Does grub start up and show you a menu of a few kernel entries to choose between during boot?
    – Kyle H
    Dec 22, 2016 at 14:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .