0

This question already has an answer here:

I'm trying to install Mate on a Ubuntu 16.04 desktop. Currently it's using Unity, but that's too much for this machine. Mate will make it usable again. I've done this on another machine, where it all worked without adding a repository. Here it doesn't work.

$  sudo apt-get install mate-desktop-environment
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package mate-desktop-environment

I've tried all these:

sudo apt update
sudo apt dist-upgrade
sudo apt install mate
sudo apt install mate-desktop-environment-core
sudo apt install ubuntu-mate-core

I've tried this repository:

sudo apt-add-repository ppa:ubuntu-mate-dev/xenial-mate
sudo apt update
sudo apt dist-upgrade
sudo apt-get install --no-install-recommends ubuntu-mate-core ubuntu-mate-desktop

This resulted in many more errors, about 50 unmet dependencies:

$ sudo apt-get install --no-install-recommends ubuntu-mate-core ubuntu-mate-desktop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ubuntu-mate-core : Depends: avahi-discover but it is not installable
                    Depends: avahi-dnsconfd but it is not installable
                    Depends: brltty-x11 but it is not installable
                    Depends: caja
                    Depends: dconf-editor but it is not installable
                    Depends: ffmpegthumbnailer but it is not installable
                    Depends: fonts-noto but it is not installable
                    Depends: fonts-noto-mono but it is not installable
                    Depends: fonts-noto-unhinted but it is not installable
                    Depends: fonts-opendyslexic but it is not installable
                    Depends: galculator but it is not installable
                    Depends: gdebi but it is not installable
                    Depends: gnome-system-tools but it is not installable
                    Depends: grub2-themes-ubuntu-mate but it is not installable
                    Depends: gufw but it is not installable
                    Depends: hddtemp but it is not installable
                    Depends: indicator-application-gtk2 but it is not installable
                    Depends: indicator-sound-gtk2 but it is not installable
                    Depends: inxi but it is not installable
                    Depends: libegl1-mesa-drivers but it is not installable
                    Depends: libqt5libqgtk2 but it is not installable
                    Depends: libtopmenu-client-gtk2-0 but it is not installable
                    Depends: libtopmenu-client-gtk3-0 but it is not installable
                    Depends: libtopmenu-server-gtk2-0 but it is not installable
                    Depends: libtopmenu-server-gtk3-0 but it is not installable
                    Depends: lightdm-gtk-greeter but it is not installable
                    Depends: mate-accessibility-profiles but it is not installable
                    Depends: mate-applet-topmenu but it is not installable
                    Depends: mate-applets but it is not going to be installed
                    Depends: mate-desktop-environment-core but it is not going to be installed
                    Depends: mate-gnome-main-menu-applet but it is not installable
                    Depends: mate-indicator-applet but it is not going to be installed
                    Depends: mate-media but it is not going to be installed
                    Depends: mate-menu but it is not installable
                    Depends: mate-netbook but it is not going to be installed
                    Depends: mate-optimus but it is not installable
                    Depends: mate-power-manager but it is not going to be installed
                    Depends: mate-themes but it is not going to be installed
                    Depends: mate-tweak but it is not installable
                    Depends: pinentry-gtk2 but it is not installable
                    Depends: pluma but it is not going to be installed
                    Depends: plymouth-theme-ubuntu-mate-logo but it is not installable
                    Depends: plymouth-theme-ubuntu-mate-text but it is not installable
                    Depends: ppa-purge but it is not installable
                    Depends: qt4-qtconfig but it is not installable
                    Depends: syslinux-utils but it is not installable
                    Depends: tilda but it is not installable
                    Depends: topmenu-gtk-common but it is not installable
                    Depends: topmenu-gtk2 but it is not installable
                    Depends: topmenu-gtk3 but it is not installable
                    Depends: ubuntu-mate-artwork but it is not installable
                    Depends: ubuntu-mate-default-settings but it is not installable
                    Depends: ubuntu-mate-lightdm-theme but it is not installable
                    Depends: xzoom but it is not installable
 ubuntu-mate-desktop : Depends: avahi-discover but it is not installable
                       Depends: avahi-dnsconfd but it is not installable
                       Depends: blueman but it is not installable
                       Depends: brltty-x11 but it is not installable
                       Depends: caja
                       Depends: compiz-mate but it is not installable
                       Depends: compiz-plugins but it is not installable
                       Depends: dconf-editor but it is not installable
                       Depends: deja-dup-backend-cloudfiles but it is not installable
                       Depends: deja-dup-backend-s3 but it is not installable
                       Depends: deja-dup-caja but it is not installable
                       Depends: exfat-fuse but it is not installable
                       Depends: exfat-utils but it is not installable
                       Depends: ffmpegthumbnailer but it is not installable
                       Depends: folder-color-caja but it is not installable
                       Depends: fonts-noto but it is not installable
                       Depends: fonts-noto-mono but it is not installable
                       Depends: fonts-noto-unhinted but it is not installable
                       Depends: fonts-opendyslexic but it is not installable
                       Depends: galculator but it is not installable
                       Depends: gdebi but it is not installable
                       Depends: gnome-system-tools but it is not installable
                       Depends: grub2-themes-ubuntu-mate but it is not installable
                       Depends: gufw but it is not installable
                       Depends: hddtemp but it is not installable
                       Depends: hexchat but it is not installable
                       Depends: ideviceinstaller but it is not installable
                       Depends: ifuse but it is not installable
                       Depends: indicator-application-gtk2 but it is not installable
                       Depends: indicator-sound-gtk2 but it is not installable
                       Depends: inxi but it is not installable
                       Depends: libaacs0 but it is not installable
                       Depends: libbdplus0 but it is not installable
                       Depends: libbluray-bdj but it is not installable
                       Depends: libbluray-bin but it is not installable
                       Depends: libbluray1 but it is not installable
                       Depends: libegl1-mesa-drivers but it is not installable
                       Depends: libimobiledevice-utils but it is not installable
                       Depends: libplist-utils but it is not installable
                       Depends: libqt5libqgtk2 but it is not installable
                       Depends: libreoffice-style-human but it is not installable
                       Depends: libtopmenu-client-gtk2-0 but it is not installable
                       Depends: libtopmenu-client-gtk3-0 but it is not installable
                       Depends: libtopmenu-server-gtk2-0 but it is not installable
                       Depends: libtopmenu-server-gtk3-0 but it is not installable
                       Depends: lightdm-gtk-greeter but it is not installable
                       Depends: lightdm-gtk-greeter-settings but it is not installable
                       Depends: mate-accessibility-profiles but it is not installable
                       Depends: mate-applet-topmenu but it is not installable
                       Depends: mate-applets but it is not going to be installed
                       Depends: mate-desktop-environment-core but it is not going to be installed
                       Depends: mate-dock-applet but it is not going to be installed
                       Depends: mate-gnome-main-menu-applet but it is not installable
                       Depends: mate-indicator-applet but it is not going to be installed
                       Depends: mate-media but it is not going to be installed
                       Depends: mate-menu but it is not installable
                       Depends: mate-netbook but it is not going to be installed
                       Depends: mate-optimus but it is not installable
                       Depends: mate-power-manager but it is not going to be installed
                       Depends: mate-themes but it is not going to be installed
                       Depends: mate-tweak but it is not installable
                       Depends: pidgin but it is not installable
                       Depends: pidgin-libnotify but it is not installable
                       Depends: pidgin-otr but it is not installable
                       Depends: pinentry-gtk2 but it is not installable
                       Depends: plank but it is not installable
                       Depends: pluma but it is not going to be installed
                       Depends: plymouth-theme-ubuntu-mate-logo but it is not installable
                       Depends: plymouth-theme-ubuntu-mate-text but it is not installable
                       Depends: ppa-purge but it is not installable
                       Depends: qt4-qtconfig but it is not installable
                       Depends: rhythmbox-plugin-cdrecorder but it is not installable
                       Depends: synapse but it is not installable
                       Depends: syslinux-utils but it is not installable
                       Depends: tilda but it is not installable
                       Depends: tlp but it is not installable
                       Depends: tlp-rdw but it is not installable
                       Depends: topmenu-gtk-common but it is not installable
                       Depends: topmenu-gtk2 but it is not installable
                       Depends: topmenu-gtk3 but it is not installable
                       Depends: ubuntu-mate-artwork but it is not installable
                       Depends: ubuntu-mate-default-settings but it is not installable
                       Depends: ubuntu-mate-libreoffice-draw-icons but it is not installable
                       Depends: ubuntu-mate-lightdm-theme but it is not installable
                       Depends: ubuntu-mate-welcome but it is not installable
                       Depends: vlc but it is not installable
                       Depends: vlc-plugin-notify but it is not installable
                       Depends: xul-ext-calendar-timezones but it is not installable
                       Depends: xul-ext-gdata-provider but it is not installable
                       Depends: xul-ext-lightning but it is not installable
                       Depends: xzoom but it is not installable
E: Unable to correct problems, you have held broken packages.

How can I install Mate on this desktop?

marked as duplicate by muru, Community Dec 22 '16 at 12:20

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Have you tried other versions of Mate desktop like core, extra etc ? – George Udosen Dec 22 '16 at 11:07
  • I've updated the question! – SPRBRN Dec 22 '16 at 11:15
  • 1
    packages.ubuntu.com/xenial/mate-desktop-environment is in Universe – muru Dec 22 '16 at 11:48
  • In the Software & Updates app I had to check all download locations under the tab Ubuntu Software. Then I could update, dist-upgrade, and install Mate. Thanks! – SPRBRN Dec 22 '16 at 12:23
0
sudo apt-add-repository ppa:ubuntu-mate-dev/xenial-mate
sudo apt update
sudo apt dist-upgrade
sudo apt-get install --no-install-recommends ubuntu-mate-core ubuntu-mate-desktop
reboot

You will be running mate. Details here and here. Hope this helps.

  • Thanks! I tried that. See my updated question. This doesn't work for me. – SPRBRN Dec 22 '16 at 11:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.