i have been searching around for about a half an hour and cannot seem to find the answer to this problem...

I just recently did a fresh install of Ubuntu 11.10 after deleting an install that used Wubi to dual boot with Windows. All I did since I installed was delete Windows partitions off my second hard drive. I just went to startup nautilus and found out that both the "move to trash" and even the "delete" command when enabled are blacked out. I then tried to click on it through nautilus and it gives me an error..

The folder contents could not be displayed. Sorry, could not display all the contents of "trash": The specified location is not supported

I already tried creating the folders under .local/share/trash and nothing has worked yet. I also already tried changing permisions and a few other things and nothing has worked. I believe that the location is probably wrong somewhere but cannot figure out where this is or how I can change it. Thanks in advance for your help.

  • It should be ~/.local/share/Trash with a capitol T. Can you check the permissions with ls -A ~/.local/share | grep Trash – Panther Dec 9 '11 at 5:15
  • Sorry if I mistyped that but i just checked and I do have the correct file structure of ~/.local/share/Trash with the two folders inside of it. When I typed ls -A ~/.local/share | grep Trash it just shows Trash in red? but i checked the file permisions through the properties of nautilus and they all seem fine. Thanks for your help though – Tommy Dec 9 '11 at 5:22
  • tommy@patrone-living-room:~$ ls -A ~/.local/share | grep Trash Trash (<-in red) tommy@patrone-living-room:~$ – Tommy Dec 9 '11 at 5:45
  • drwxrwxrwx 4 tommy tommy 4096 2011-12-08 23:18 Trash – Tommy Dec 9 '11 at 6:03
  • 1
    @Tommy Welcome to askubuntu! The way this site works is for you to edit your question and then put the output of your commands there, this bumps your question and ensures information isn't buried in comments, thanks! – Jorge Castro Dec 9 '11 at 22:41

Although I'm on a Debian distro, this should work for Ubuntu as well: (re)install gvfs-backends, log out and in and you should be fine. For some users installing gvfs-fuse worked. Be sure to have all appropriate users in the fuse group.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.