8

After I installed Android studio 2.2.3 on Ubuntu 14.04 LTS this problem bugs me for hours:

Error message

I've checked the bios and it shows that vt-x is supported but I receive

me@pc:~$ kvm-ok 
INFO: /dev/kvm does not exist
HINT:   sudo modprobe kvm_intel
INFO: For more detailed results, you should run this as root
HINT:   sudo /usr/sbin/kvm-ok

in my terminal. I have also installed kvm follwing this tutorial and I can see:

me@pc:~$ egrep -c '(vmx|svm)' /proc/cpuinfo
8


me@pc:~$ virsh -c qemu:///system list
 Id    Name                           State
----------------------------------------------------

But emulator still refused to load.

me@pc:~$ uname -a
Linux pc 3.13.0-98-generic #145-Ubuntu SMP Sat Oct 8 20:13:07 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

I get this error on the studio's console:

Error while waiting for device: Could not start AVD

I'm really ran out of ideas. I appreciate your help.

UPDATE:

root@pc:/home/me# sudo /usr/sbin/kvm-ok
INFO: /dev/kvm does not exist
HINT:   sudo modprobe kvm_intel
INFO: Your CPU supports KVM extensions
INFO: KVM (vmx) is disabled by your BIOS
HINT: Enter your BIOS setup and enable Virtualization Technology (VT),
      and then hard poweroff/poweron your system
KVM acceleration can NOT be used
1

The error you get when you try the command kvm-ok gives you two other commands which may resolve your problem :

  1. sudo modprobe kvm-intel(with intel CPU, replace, with -amd for AMD ones) or sudo modprobe kvm : this will load the kvm virtualisation module into the kernel, allowing VM to run properly.

  2. running sudo /usr/sbin/kvm-ok : will run it as root.

The first one is the most likely to work, so try it first, and then run the second one.

EDIT :

I just noticed in your answer that you said your BIOS supported it, but not that it was enabled... It's probably just a misunderstanding from me, but check anyway...

  • 1
    I get this at 1: modprobe: ERROR: could not insert 'kvm_intel': Operation not supported – Karlom Dec 21 '16 at 18:47
  • Yes, please refer to update for the output. – Karlom Dec 21 '16 at 18:48
  • Oh, my fault : it's kvm-intel and not kvm_intel :/ (By the way, there's a documentation page about it here – cocosushi Dec 21 '16 at 18:49
  • Interestingly , sudo modprobe kvm-intel also results in modprobe: ERROR: could not insert 'kvm_intel': Operation not supported – Karlom Dec 21 '16 at 18:53
  • @Karlom yes, probably. Try re-runing kvm-ok – cocosushi Dec 21 '16 at 18:55
2

I had the same problem: couldn't run AVD (Nougat x86_64 image). How I solved: just enabled Intel Virtualization Technology in BIOS (at BIOS Features section for my Gigabyte motherboard).

See also this post.

-1
  1. sudo apt-get install qemu-kvm libvirt-bin ubuntu-vm-builder bridge-utils

  2. sudo adduser id -un libvirtd

  3. sudo adduser id -un kvm

Then log out and back in again, and check that it is working by running:

virsh -c qemu:///system list

  • read the description carefully. I did all these from the tutorial that I've mentioned. – Karlom Dec 21 '16 at 18:37
  • 1
    -un is a invalid option.. – Siddharth Jun 14 '18 at 11:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.