17

I have Ubuntu 16.10 (although the same happened on 16.04) on a dual boot with Windows 10. I noticed some time ago that my kern.log file was getting pretty big (10GB or more) so I decided to check it. The same error seems to be repeating every second or less:

Dec 19 17:31:01 andrew kernel: [   99.027473] pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e5(Receiver ID)
Dec 19 17:31:01 andrew kernel: [   99.027474] pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00000001/00002000
Dec 19 17:31:01 andrew kernel: [   99.027475] pcieport 0000:00:1c.5:    [ 0] Receiver Error        
Dec 19 17:31:01 andrew kernel: [   99.027479] pcieport 0000:00:1c.5: AER: Corrected error received: id=00e5
Dec 19 17:31:01 andrew kernel: [   99.027826] pcieport 0000:00:1c.5: can't find device of ID00e5
Dec 19 17:31:01 andrew kernel: [   99.027887] pcieport 0000:00:1c.5: AER: Multiple Corrected error received: id=00e5

I have tried adding to the grub pci=nomsi and pci=noaer but it keeps popping up. I am using a ASUS Laptop with an Nvidia Geforce 920M. Maybe that's the reason?

11

I believe this may be due to PCIe Active State Power Management that is transitioning the link to a lower power state and maybe causing the device to trigger these errors. I believe the device in question is the Sunrise Point-LP PCI Express Root Port.

Try using the pcie_aspm=off boot parameter to see if this stops the messages. Note that this will increase the power consumption of your machine as it disables the power savings.

  • Seem to solve the problem. Thanks a lot!! – Andrew Dec 22 '16 at 14:20
  • In my case I noticed it because systemd-journal caused high cpu usage. Adding the parameter helped. I read however, that this disables some energy saving measures. Probably all for PCIe devices (?) – Zelphir Feb 10 '17 at 0:10
  • pcie_aspm=off does indeed disable PCIe power savings. There are in fact two savings modes: L0s and L1 mode. L0 uses low power mode for one direction of the PCIe serial link only. L1 is bidirectional, resulting in improved power reduction (but does incur higher startup latencies). – Colin Ian King Feb 10 '17 at 0:17
  • see askubuntu.com/questions/271058/… – Ferroao Jun 30 '17 at 18:54
  • I believe this is the best answer. pci=nomsi disables some interrupts and noaer just disables error reporting, not the actual problem. See also askubuntu.com/a/1066030/284929 – wbkang Dec 20 '18 at 3:43
4

Try these steps:

  1. sudo gedit /etc/default/grub
  2. Edit grub. Add pci=noaer at the end of GRUB_CMDLINE_LINUX_DEFAULT. Line will be like this:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=noaer"

  3. sudo update-grub

  4. Reboot now

:) Enjoy.

  • This worked for an ASUS X541U laptop. – kraxor Oct 9 '18 at 13:59
1

I had the same problem, but the solution was to add pci=nomsi to /etc/default/grub file. Perform the following edit:

before:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

after:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"

And save the settings:

sudo update-grub
  • 1
    On my system sudo grub-update did not work. sudo su and grub-update did. – RobAu Apr 26 '18 at 7:03
  • Thanks for your comment @RobAu . The answer updated to address your concern – Roozbeh Zabihollahi May 2 '18 at 22:56
  • Thanks, solved problem on an Lenovo notebook. – tardis Feb 3 at 16:39
1

I installed Ubuntu 18.04 today and I noticed the same problem. I've just installed that package and problem has been solved.

sudo apt-get install busybox-syslogd

Check log files size and do empty large files:

ls -s -S /var/log

result:

total 4352668
4021088 syslog                 32 wtmp                  4 gdm3
 329168 kern.log               24 Xorg.0.log            4 hp
   1776 dpkg.log               20 Xorg.1.log            4 installer
     40 lastlog                20 Xorg.0.log.old        4 journal

and do:

cd /var/log
sudo su
$ > syslog
$ > kern.log

Then, to make sure, let follow this answer above https://askubuntu.com/a/1019225/725320

In case you can't boot into Ubuntu and get stuck with these logs in your screen (same as me):

Dec 19 17:31:01 andrew kernel: [   99.027473] pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e5(Receiver ID)
Dec 19 17:31:01 andrew kernel: [   99.027474] pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00000001/00002000
Dec 19 17:31:01 andrew kernel: [   99.027475] pcieport 0000:00:1c.5:    [ 0] Receiver Error        
Dec 19 17:31:01 andrew kernel: [   99.027479] pcieport 0000:00:1c.5: AER: Corrected error received: id=00e5
Dec 19 17:31:01 andrew kernel: [   99.027826] pcieport 0000:00:1c.5: can't find device of ID00e5
Dec 19 17:31:01 andrew kernel: [   99.027887] pcieport 0000:00:1c.5: AER: Multiple Corrected error received: id=00e5
  • Use Recovery Mode to get root shell
  • Do empty large log files
  • Boot into Ubuntu, install busybox-syslogd and update grub config
0
  1. if you already installed ubuntu or mint just go from the grub and from there go to recovery mode from there go to root and make the commands like on the video and from there make the changes again like in the video BUT if pci=nomsi/pci=noaer does not work for you change it to pcie_aspm=off.

  2. if you can not install the OS cause of this problem you can edit the boot order line in grub if you dont understand me when you boot up for a installation instead of pressing ENTER press E to edit and there is a line named Linux and add to the end pcie_aspm=off but try out pci=nomsi/pci=noaer (REMEMBER THIS IS NOT A PERMANENT FIX TO FIX IT PERMANENT DO STEP 1 AFTER THE INSTALATION) AND DO NOT FORGET TO UPDATE THE GRUB

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.