First off, my laptop is a POS, so I haven't ruled out a hardware malfunction, but in the hopes that I don't have to have the WiFi component replaced along with the failing hard disk, I'm making the assumption that maybe something is wrong with my configuration of Ubuntu 11.10. Also, I'm a programmer and I know basic things like ping, ifconfig, and pretty basic terminal commands, but I'm still really new to Ubuntu.

My problem is my laptop can't surf the net. I'm running Ubuntu 11.10 via LiveUSB, and connect to the internet via a WiFi connection. I know it's not the connection itself because other laptops manage to connect and surf the web. I doubt it's the connection to the router because I manage to access the router's config page by entering on the address bar of Firefox. I've tried to access the internet via my home connection and my schools' connection (the proxy for this connection was configured), but both attempts failed. I also tried playing with the checkboxes in the IPv4 and IPv6 tabs of the network settings with no luck. Firefox just keeps saying I can't access the net. I've also tried pinging Google, but it says it can't find the server Server cannot be found. I'm pretty sure it's a DNS issue because I managed to access google.com by entering their IP address: It loaded the page, but failed to load the links. I did a port scan on and it reports one open port, 6xx (I can't remember which port exactly). I checked my resources, and it shows small network transfers, but that's all. I have no idea what other settings I can tweak, so any advice on how to fix this would be appreciated.

EDIT: I connected to the WiFi at the office. It still won't work, but I managed to ping in ~50 ms Running ip route show printed the following: dev wlan0 scope link metric 1000 dev wlan0 proto kernel scope link  src metric 2

I don't know what any of that means.

  • Since you can view the router's config page, it could be a routing problem - could you paste the output of ip route show? The other option is that DNS resolution isn't working, can you ping Dec 9, 2011 at 3:25
  • I'll paste it as soon as I get home. I don't think it's a problem with the router though. Other devices connected to it have access to the internet.
    – cesar
    Dec 9, 2011 at 4:30
  • A routing problem, not a router problem :). Dec 9, 2011 at 4:34
  • oh, okay. my bad. I'll post in around 5 hours, but I can't right now.
    – cesar
    Dec 9, 2011 at 4:36
  • I also get a failed command: READ DMA EXT error.
    – cesar
    Dec 9, 2011 at 10:53

1 Answer 1


I fixed the problem by getting a new copy of Ubuntu 11.10. The internet works fine now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.