7

I have a problem with the gvfs daemon

I have a mounted gvfsd-fuse

$ mount | grep gvfs
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)

on pc1 (not using ssh)

$ gvfs-info -w $HOME
<...>
Writable attribute namespaces:
metadata (string, Copy with file, Keep with file when moved)
xattr (string, Copy with file, Keep with file when moved)
xattr-sys (string, Keep with file when moved)

but when I log with ssh on this machine

$ ssh -X user@pc1
$ gvfs-info -w $HOME
<...>
Writable attribute namespaces:
xattr (string, Copy with file, Keep with file when moved)
xattr-sys (string, Keep with file when moved)

The metadata part is missing, which is needed when I use nautilus over ssh and I change the per folder settings (i.e. zoom or file sorting).

$ ssh -X user@pc1
$ nautilus
=> changing the zoom level for example, then change folder, go back, the zoom setting is lost (reset to default)
this does not happen when I log physically on this machine.

1 Answer 1

3

Ok so I found an answer after a few hours.

It seems that the dbus daemon is not launched for the remote ssh session.

So using the existing DBUS_SESSION_BUS_ADDRESS was failing, but I found a solution HERE:

$ ssh -X user@pc1 "gnome-terminal -e 'dbus-launch --exit-with-session bash'"
$ nautilus

I starts up a new session bus or find the existing bus address on the X display, so that the aplication can communicate with the gvfs daemon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.