0

I'm trying to set up ubuntu on my windows machine using virtualbox but I keep getting the following error after a few seconds of running the installation:

end kernel panic - not syncing: vfs: unable to mount root fs on unknown block(0,0)

I have ensured that Hyper V is disabled and virtualization is enabled in BIOS (those are the suggestions I found online) This is my first time trying to use Linux. I got the iso file from the ubuntu website

How do I fix this

  • I don't run Linux already. I have no access to 'grub' or 'sudo' – segunolalive Dec 21 '16 at 12:24
  • you are right. my bad. you need to change virtual hdd controller type used for the guest in virtualbox to SATA as explained here. – kashish Dec 21 '16 at 12:41
  • It was set to SATA by default. Not working – segunolalive Dec 21 '16 at 14:05
  • The problem was with the iso file. It probably got corrupted during download. I followed the instructions on Ubuntu website to verify that the iso was fine but it failed the test. Thanks – segunolalive Dec 21 '16 at 21:41
-1

If grub is accessible:

Remove old linux kernels, your /boot drive is out of space.

  • Boot to grub and click on “Advanced options”
  • Select a previous kernel (should boot fine)

login and enter command

$ df

See if your /boot directory is 100% used Remove old linux kernels

$ sudo apt-get autoremove

from here: Geekdecoder

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.