3

Using information from here: link to info about installing Nvidia drivers

I installed an Nvidia driver. I have Ubuntu 16.04 and the Nvidia GT 710. I believe this video card was a new model around early 2016 and made to target older desktops or small form factors. I put it into an old server.

I used nvidia-304 because it is for the 7 series and it was built 4 days ago. It doesn't work because the login dialog performs an infinite loop.

The infinite loop is as follows:

display login dialog... type password... screen goes black... display login dialog... etc.

This is what I did:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get upgrade
sudo apt-get purge nvidia*
sudo apt-get install nvidia-304

I also tried

sudo apt-get install nvidia-current and

sudo apt-get install nvidia-340 and

sudo apt-get install nvidia-367 and

sudo apt-get install nvidia-370 and

sudo apt-get install nvidia-375

but they have the same problem.

I've read that it is wrong to download and use the *.run file from Nvidia so I didn't do that.

I have read the ~/.Xauthority file might have incorrect ownership leading to an inability to login but I checked ownership and it is my user name not the root.

There is also the suggestion at this link to Ctrl-Alt-F1 in order to do this:

sudo mv ~/.Xauthority ~/.Xauthority.backup
sudo service lightdm restart

However, Ctrl-Alt-F1 does not seem to produce a command line interface for me.

What is the solution?

4

As Marc Vanhoomissen has said, there are many questions and many solutions about this problem on askubuntu.com. Many of them don't work in my case.

Here is the solution that worked for me at this link.

Here's the text reproduced from that link:

Here is modern way to install the nvidia drivers for Ubuntu (for 14.04 and newer)

        sudo add-apt-repository ppa:graphics-drivers/ppa
        sudo apt-get update
        sudo ubuntu-drivers autoinstall
        sudo reboot

I would add that if you have had many failed attempts you should start with

sudo apt-get purge nvidia* and

sudo apt-get autoclean and

sudo apt-get autoremove nvidia* and

shutdown and power-off and reboot before installing the driver in the suggested manner.

| improve this answer | |
  • In two days time don't forget to check your answer as the correct solution. You can improve your answer by including a summary of the steps detailed in the link. – WinEunuuchs2Unix Dec 22 '16 at 0:59
2

This method works only if you have multiple GPUs connected to your system.

First you have to follow H2ONaCl's answer. But sudo ubuntu-drivers autoinstall will not always update all the drives of your GPUs.

You can check your available GPUs by sudo ubuntu-drivers devices command and check the versions of the latest drivers that are available for your GPUs.

Then type sudo apt-get install nvidia-version for all GPU versions available in your system.

You can check installed drivers by nvidia-smi command and check whether all the available GPUs have drivers available.

This methods worked for me for a project that I'm doing using GeForce 8400GS and Tesla K40c GPUs with Ubuntu 16.04.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.