1

I decided that I want to dual boot Windows 10 and Ubuntu 16.04.1 LTS as safely as possible by using two hard drives. I disconnected the old windows 10 hard drive and installed Ubuntu on another new drive. After the installation was completed, I tried to run os-prober but nothing came up. Grub also didn't show at first until I commented out the line # GRUB_HIDDEN_TIMEOUT=0. Now GRUB only shows Ubuntu and no Windows 10. I can still access windows 10 without any problems by changing the boot priorities in my bios. I disabled secure boot and fast boot in windows 10 already. The boot menu in my bios shows UEFI and Legacy mode for the boot mode. Both systems are intact and undamaged because they were installed separately. The windows 10 drive is mounted (shows on the side bar as a 249GB volume) as I am running os-prober.

Is there a way that I can get grub to detect windows 10?

Let me know if there is any configuration file or screen shots you would like to see.

1

try installing Ubuntu boot repair, I have used it before for fixing boot errors and I had a similar problem and it resolved it for me. https://help.ubuntu.com/community/Boot-Repair You can install on your running system or download an iso and create a boot disk from that for boot repair. both ways work equally as well.

1
  • I ran boot repair as you said to do. This is the output that it gave me. GPT detected. Please create a BIOS-Boot partition (>1MB, unformatted filesystem, bios_grub flag). This can be performed via tools such as Gparted. Then try again. Alternatively, you can retry after activating the [Separate /boot/efi partition:] option. What should I do next? Should I boot into the live USB and use Gparted – kevinchangwang Dec 22 '16 at 2:03
0

There was some kind of error in grub that caused it to do this. I did a reinstall of Ubuntu and it fixed the problem. I also booted into the flash drive in legacy mode instead of UEFI mode. In addition, I checked use LVM so that if I need to create partitions, I can do so easier than before.

The new install worked just fine. Grub did glitch a bit for the first few boots where it would register the arrow key as the e key upon clicking it first. The problem went away after a couple of reboots.

1
  • If Windows is UEFI, you always want to boot Ubuntu & installers or repair disks in UEFI boot mode. A few systems need Legacy mode on, but still let you boot in UEFI mode. Most have to have Legacy/BIOS/CSM off to boot in UEFI mode. LVM is an advanced configuration. You cannot use standard partition tools but must use LVM tools. wiki.ubuntu.com/Lvm – oldfred Dec 24 '16 at 5:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.