0

I am using Google Chrome 15.0.874.121 in Ubuntu 10.10. It was fine until recently. Whenever download a file, it always reports "Interrupted", but it actually finishes the downloading, leaving an intermediate file with extension ".crdownload". If removed the extension, the file will be perfect.

Note that downloading in Firefox works fine at the same time.

So I wonder if it is a bug or how I can fix it?

Thanks and regards!

1

It seems like apparmor is blocking Chromium to save files to non standard directories. I expected adjusting the /etc/apparmor.d/abstractions/user-download file would do the trick, but it only fixed the same issue I had with Firefox. In Chromium I'm still getting the same interrupted downloads when saving to external media.

I added owner /media/** rwl, to /etc/apparmor.d/abstractions/user-download.

There seem to be issues with the current Chromium build related to this, causing the error when saving to NTFS / FAT file systems as these don't support chmod. Link to issue on Chromium codebase

I just tested with a daily stable build from their ppa but this doesn't help.. Version is 16.0.912.75 (Developer Build 116452 Linux) Ubuntu 11.10

0

Is there space on your hard disk for the file you are trying to download?

Check it with the command df. If so, try to download the file with other browser or with wget and if the problem persists, reinstall the application.

  • Yes, there is space. If not, how can firefox download have no problem? – Tim Dec 9 '11 at 1:22
0

Have you tried to set the downloads folder to an ext3/4 partition? I had the same problem, only with chrome, and thanks to this post: http://code.google.com/p/chromium/issues/detail?id=102200 I changed the default location to my ext4 partition, and downloads are working fine now.

  • Thanks! I download to ext4 partition when the problem happens. So I am not sure I understand what you suggested. – Tim Dec 21 '11 at 13:44
-1

Change you Google Chrome "Download Directory" from Options to some other Directory other than C:\ Drive (like say D:). It will help. Becz there is done wrong in your system directory that why it is not allowing you to save in C: drive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.