-1

I have a machine with Ubuntu 16.04 installed, and recently installed a FirePro V7900. I went to try and installed the drivers, fglrx-15.201.2401, but the kernal header or something in /lib/modules/4.4.0-53-generic/build/include/linux/version.h is missing. I googled this a bit and tried to some other fixes but they don't seem to work for this driver. I tried just copying version.h but I can't for some reason even as the sudo user. The error is displayed in the file as

fglrx installation requires that the system has kernel headers.  /lib/modules/4.4.0-53-generic/build/include/linux/version.h cannot be found on this system.
Install kernel headers using the command apt-get install linux-headers-4.4.0-53-generic.

It seems they changed out the files are stored but AMD never got the memo or this card is just older so they aren't worried. Anyone have any reasonable solutions?

2

Ubuntu 16.04 doesn't support AMD's old FGLRX drivers. I have GCN 1.0 graphic card and I can't run it on Ubuntu as well. They even pushed new update in 14.04 where FGLRX don't work anymore. I don't know if your graphic card is GCN or not. If it is not GCN, then forget about Ubuntu. Go to other Linux distributions like Linux Mint 17.3 for FGLRX.

Edit: I have just checked that your GPU is TeraScale 3 not GCN. You have no other option but to go to older version of Linux distribution which is not Ubuntu. Try Linux Mint or try DistroWatch.com website to find a Linux distribution for your computer. Also you might want to replace your GPU with latest / newer graphic card.

  • Yeah I just got this one, a new AMD firepro costs many times what I'd be willing to pay for one. – Joshua A. Nicoll Dec 20 '16 at 12:06
  • 1
    FirePro cards are professional graphic cards. Gaming cards are much cheaper than professional cards. – Faisal Aslam Dec 20 '16 at 12:20
  • I'm not using it for gaming, I have an R9 380X for that, it's for a U1 rack chassis, only single slot cards fit in. It's for OpenCL compute, not gaming. – Joshua A. Nicoll Dec 22 '16 at 10:56
-1

I found this in another answer on compiling, but it fixed the driver install for the same card:

sudo ln -s /usr/src/linux-headers-$(uname -r)/include/generated/uapi/linux/version.h /usr/src/linux-headers-$(uname -r)/include/linux/version.h

taken from: Help locating linux/version.h

  • If this answers the OP's problem, it would be better to simply flag his question as a duplicate. – anonymous2 Feb 7 '17 at 18:40
  • @anonymous2 It would be better to simply flag his question as a duplicate, but in this case it's impossible because user651886 doesn't have the 15 reputation required to flag. – karel Aug 2 '17 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.