2

I am using http://www.canyouseeme.org and http://www.yougetsignal.com/tools/open-ports/ to find out whether my port is opened for connection or not.

I am not able to seed the torrents. It keeps telling me that seeding port is closed from external IP. Not only seeding port but all the ports are closed for incoming connections.

I am using qbittorrent.

What I have tried:

  • In my router N6400 I have enabled port forwarding and UPnP.
  • Without firewall, I tried iptables command for specific port but didn't worked.
  • With firewall, I added inbound rules for port but it didn't work.

I have tried by directly connecting my laptop to Modem via LAN but still port was closed so router does not have any problems with port forwarding.

Here is the output of ntlp | grep 8999

tcp  0   0 172.21.20.219:8999      0.0.0.0:*      LISTEN      4459/qbittorrent
udp  0   0 172.21.20.219:8999      0.0.0.0:*                  4459/qbittorrent  
10
  • Several problems could be happening simultaneously. Just because the problem still shows up when you remove the router doesn't mean there's not also a problem with the router. In fact, a lot of ISPs won't allow a new MAC address to work with the modem, so it's possible you've added another problem. Dec 20, 2016 at 3:51
  • @ChaiT.Rex What can be done in this situation ?
    – JBaba
    Dec 20, 2016 at 15:56
  • What are you trying to do? Open external ports for qBitTorrent? Try turning Port Forwarding off in the router first. If that doesn't work, try sudo ufw disable.
    – Fabby
    Dec 22, 2016 at 11:58
  • @Fabby I am not able to seed the torrents. It keep telling me that seeding port is closed from external IP. Firewall is already turned off.
    – JBaba
    Dec 22, 2016 at 16:17
  • 1
    What IPv4 address are you using for testing? Does your ISP provide you with full IPv4 connectivity on a public address, rather than something like Carrier-Grade NAT ? Dec 22, 2016 at 16:42

2 Answers 2

2

As you can see, the local address on those sockets is 172.21.20.219, which is a private IP address, and presumably not the one that your traffic is actually coming to. If the sockets were listening on any port, they would display 0.0.0.0:8999 or :::8999. The problem lies with qbittorrent, that it's binding to that address specifically.

4
  • how do you change this binding from QBittorrent ?
    – JBaba
    Dec 22, 2016 at 16:46
  • @JBaba I've never used it. Look in the settings for anything like "bind address" or "bind interface".
    – hobbs
    Dec 22, 2016 at 16:47
  • I changed this configuration now it show my local ip. But still it says port is closed.
    – JBaba
    Dec 22, 2016 at 18:26
  • @hobbs even 80 port is closed for incoming connections. I have changed settings which is what you suggested.
    – JBaba
    Dec 24, 2016 at 14:59
0
+100

There three interfaces up:

lo   127.0.0.1    ##local loopback
tun0 172.21.20.45 ##VPN tunnel
wlo1 192.168.1.2  ##LAN Interface

So the port forwarding is correct with 192.168.1.2 local IP from the router.

The issue seems with qbittorrent that seems configured to use only tun0 interface.

  1. From qbittorrent menu: Tools → Options... → Advanced → Networ Interface: Select Any Interface
  2. Restart qbittorrent

Check netstat -ntlp | grep 8999, you should find: 0.0.0.0:8999

qbittorrent interface bind settings

10
  • I have tried that but as this ip is not registered under router. So if try to choose port forwarding on 172.21.20.219 this it gives me invalid ip address error.
    – JBaba
    Dec 24, 2016 at 15:36
  • 192.168.1.2 this static ip assigned by router. And 172.21.20.219 is interface ip assigned by Qbt. please tell me how to do correct setup ?
    – JBaba
    Dec 24, 2016 at 15:40
  • @JBaba, Could you post the output of ifconfig -a and route commands plus the DHCP page from router. It seems you have dual subnet setup (possible wrong)
    – user.dz
    Dec 24, 2016 at 15:45
  • please see the requested output
    – JBaba
    Dec 24, 2016 at 15:55
  • 172.21.20.45 this is my current interface ip for Qbt
    – JBaba
    Dec 24, 2016 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.