4

Is there a way to get a program (i.e. Firefox) to execute with the nice command from the Launcher ("nice firefox")? Saw one (1) post elsewhere saying you could right-click the Launch icon and select "Edit command," but mine do not seem to have that option. (Ubuntu 14.04 LTS)

5
  • It's certainly possible to edit those launcher files but its not recommended. There's a couple alternative ways that i can think of, for example via top panel indicator, but i don't see a unity launcher solution. – Sergiy Kolodyazhnyy Dec 19 '16 at 22:00
  • Another alternative would be via the CLI as in nice -10 /opt/google/chrome/google-chrome or nice -10 firefox (If the executable isn't on your path you need to provide it in full.) – Elder Geek Dec 19 '16 at 23:11
  • @Elder Geek: ...Which begs another question: Can you start shell scripts from Launch? (I have no aversion to using the CLI, just looking for alternatives using Launch.) – NathanH Dec 19 '16 at 23:54
  • 1
    @NathanH Of course! askubuntu.com/questions/141229/… – Elder Geek Dec 20 '16 at 12:59
  • Thanks for all the responses; appreciate the help. Flag this one "complete." – NathanH Dec 20 '16 at 17:43
7

Imo the best way to do that is adding a right- click (quicklist) entry to the firefox launcher. There are a few options:

1. Manually

  1. copy the firefox launcher from /usr/share/applications to ~/.local/share/applications

    cp /usr/share/applications/firefox.desktop ~/.local/share/applications
    
  2. Open the file with (e.g.) gedit, Look for the line starting with:

    Actions=
    

    Add "Nice firefox" to the line:

    Actions=NewWindow;Nice firefox;
    

    Add to the very bottom of the file a section:

    [Desktop Action Nice firefox]
    Name=Nice firefox
    Exec=nice -10 firefox
    
  3. Now save the file, log out and back in. A new entry appears:

    enter image description here

2. Use a GUI quicklist editor

...like this one

enter image description here

After installing, open the editor, choose the firefox launcher from the list (no need to say it needs to be locked to the launcher), and click the big + to add your entry.

To install:

sudo add-apt-repository ppa:vlijm/qle
sudo apt-get update
sudo apt-get install qle
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.