2

I'm using Kubuntu 14.04. I lost my desktop and got error unable to launch "/usr/bin/startkde" X sesssion - "/usr/bin/startkde" not found; falling back to default session. I found a possible fix in a post and I followed the instruction by entering the terminal using Ctrl+Alt+F1:

sudo apt-get update
sudo apt-get install -f
sudo apt-get dist-upgrade
sudo apt-get install kubuntu-desktop

The last command results unmet dependencies problem and I got stuck.

enter image description here

[UPDATE]

The result of apt-cache policy kubuntu-desktop kde-workspace plasma-desktop plasma-netbook looks like

enter image description here

I encountered the similar problem before that I could successfully install the desktop, but I think this case is little different from it.

  • 1
    Can you add the output of apt-cache policy kubuntu-desktop kde-workspace plasma-desktop plasma-netbook (you could add more of the listed packages to the command, but that should be enough as a start) to your question, please? Plain, code-formatted text is preferred over screen photos though, if possible. – Byte Commander Dec 19 '16 at 17:12
  • @ByteCommander Please check the update for apt-cache in the question. I can't copy and paste the texts as I can't use mouse in the terminal without desktop. The screens had to be taken by mobile camera. – Sithu Dec 20 '16 at 2:27
  • Have you tried installing the missing packages ? – Johnny Dec 20 '16 at 3:24
2

It seems you was upgrading kubuntu, but then somehow lost connection in the middle of process.

The plausible fix is to reinstalling kubuntu-desktop package, although the command you run is right. Have you tried manually installing the missing packages that listed on it is not going to be installed?

sudo apt-get install kde-workspace plasma-desktop plasma-netbook software-properties-kde kadressbook apturl-kde apport-kde akregator kde-telepathy kdepim-kresources kdepim-runtime kmail knotes kontact korganizer muon-discover muon-notifier plasma-runner-telepathy-contact plasma-widgets-addons usb-creator-kde
  • Manually appending all listed packages to the install command is what I would have suggested next, too. You should try that @Sithu. – Byte Commander Dec 20 '16 at 12:04
  • @ByteCommander Please check my answer below and my follow-up question. – Sithu Dec 20 '16 at 16:08
2

Figuring out the unmet dependencies drilling down one by one solved the problem.

apt-get install kubuntu-desktop
apt-get install kubuntu-workspace
apt-get install kubuntu-workspace-bin
apt-get install plasma-desktop
apt-get install plasma-dataengines-workspace
apt-get install kdepim-runtime
apt-get install akonadi-server
apt-get install akonadi-backend-mysql

When I tried the above commands one-by-one, the dependency requirements stopped at akonadi-backend-mysql. I noticed mysql 5.6 was removed during akonadi-backend-mysql installation. Just before my desktop lost, I upgraded mysql 5.5 to 5.6. Probably it made the desktop broken.

Finally I successfully got my desktop back by running these commands, but I lost mysql 5.6.

apt-get install kubuntu-desktop
apt-get install kubuntu-desktop --fix-missing

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.