2
  • I have keys setup on my Linux headless server and Putty on my Windows Desktop.

  • I can connect and authenticate successfully with Putty and authentication is via RSA Keys.

However, if I disable password authentication in sshd_config (PasswordAuthentication no) when I try and connection with Putty I get:

Server refused our key

And yet, if I then enable password authentication again, the key authentication works!

In addition, if I reset permissions of the /.ssh folder and authorized keys to 0700 and 0644, respectively.

I am able to disable password authentication and use the RSA Keys only until system reboot which then returns server refused our key again....

1

I had the home directory encrypted, this seems to have been the cause. I re-installed and set up SSH again and it worked fine, as soon as the home directory is encrypted, ssh keys won't work without enabling password authentication in sshd.config - must be a workaround for this but for now this works for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.