0

After two days of googling and searching askubuntu i decided to start a thread.

Here's my problem:

I recently exchanged my server (running Lubuntu 12.04 with ssh service and a game service) for a newer one (running Lubuntu 16.04). The network card stays the same, I built it in the new server. After setting up the new server with those two services I could only connect from inside the LAN. Everytime I tried connecting with my mobile data the connection timed out. GRC's ShieldsUP! shows the two ports i use as Stealth, other ports as Closed.

Here's what I've tried:

  • Connecting my old server again - both services worked, ShieldsUP shows the ports as Open, so Port forwarding and DNS resolving can't be the problem.
  • disabling ufw (is there another sort of firewall which could be blocking ports?)
  • enabling ufw and allowing the Ports
1

I've found the answer, the problem was just a faulty routing table. It preferred the wired network card over the Wi-fi card i was actually using.

so

route del -net 0.0.0.0 gw 192.168.0.2 netmask 0.0.0.0 dev enp0s10

did it for me.

  • I would mark this as answered, but askubuntu won't let me for the next two days. I won't delete the thread though, might be helpful for someone. – HighDraw Dec 19 '16 at 0:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.