1

I have this ralink 3290 wifi. it s not working well. I did the first reinstallation and had it working on the fly. now by rebooting wifi dies or is not alive at anyway.

here is some outputs

abcdef@abcdef-HP-Pavilion-17-Notebook-PC:~/Downloads$ lspci | grep Network
02:00.0 Network controller: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe
abcdef@abcdef-HP-Pavilion-17-Notebook-PC:~/Downloads$ 
abcdef@abcdef-HP-Pavilion-17-Notebook-PC:~/Downloads$ sudo lshw -C network
  *-network UNCLAIMED     
       description: Network controller
       product: RT3290 Wireless 802.11n 1T/1R PCIe
       vendor: Ralink corp.
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f0210000-f021ffff
  *-network
       description: Ethernet interface
       product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: eno1
       version: 07
       serial: a0:d3:c1:63:0d:0d
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8106e-1_0.0.1 06/29/12 ip=192.168.0.105 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:31 ioport:2000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff memory:f0010000-f001ffff
abcdef@abcdef-HP-Pavilion-17-Notebook-PC:~/Downloads$ 

anybody to help me activate this correctly ? thank you by advance.

  • Comments are not for extended discussion; the entire conversation that was taking place here has been moved to chat. – Thomas Ward Dec 22 '16 at 0:26
  • Could you please add the output of lspci -nnk | grep -i net -A2 to see which driver is in use and the output of iw dev to see if there is a interface name. – Hölderlin Dec 23 '16 at 5:18
  • jpst.it/QOxn – JFab Dec 25 '16 at 9:21
  • Please edit your question and replace your long output with the short summary of lspci -nnk | grep -i network -A2, rfkill list and iw dev | grep Interface. – Hölderlin Dec 25 '16 at 14:36
  • abcdef@abcdef-HP-Pavilion-17-Notebook-PC:~$ lspci -nnk | grep -i network -A2 02:00.0 Network controller [0280]: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe [1814:3290] DeviceName: Ralink WLAN Ralink RT3290LE Roma 802.11bgn Wi-Fi Subsystem: Hewlett-Packard Company Ralink RT3290LE 802.11bgn 1x1 Wi-Fi and Bluetooth 4.0 Combo Adapter [103c:18ec] abcdef@abcdef-HP-Pavilion-17-Notebook-PC:~$ rfkill list abcdef@abcdef-HP-Pavilion-17-Notebook-PC:~$ iw dev abcdef@abcdef-HP-Pavilion-17-Notebook-PC:~$ iw dev | grep Interface abcdef@abcdef-HP-Pavilion-17-Notebook-PC:~$ – JFab Dec 25 '16 at 18:51
0

I am using asus X450cc and my wifi card it rt3290. This is what worked for me

I downloaded the rt3290 Driver from here, extracted it and entered the directory and ran

sudo ./run.sh

This requires a working ethernet connection.

Then I also tried How to install wifi driver Ralink RT3290 and How do I get an RT3290 wireless card to work?

Then I tried:

rfkill unblock all

I also tried:

sudo apt-get update
sudo apt-get install firmware-b43-installer b43-fwcutter
sudo reboot

Finally I tried:

sudo ifconfig enp3s0f0 up  #(here this is my logical name of wifi change it to your wifi name)
sudo pm-suspend

Now my wifi is working, although I still have a tiny problem; every time I boot into Ubuntu I need to suspend and resume, only then does my wifi work.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.