0

I tried to upgrade Ubuntu from 14.04 to 16.04, but must have removed some important kernels. I'm not sure about this, but now everytime I try to boot the system ,there's only memtest86+ running over and over. The situation very much like here: Updated Ubuntu 16.04 and Now stuck in memtest86+

I tried to follow this manual: https://ubuntuforums.org/showthread.php?t=1599293

I do this in a command line. I manage to follow some steps, but I can't locate the Ubuntu ISO file! Here's what I get:

grub> ls
(hd,0) (hd0,msdos5) (hd0,msdos1)
grub> ls (hd0)/
error: unknown filesystem
grub> ls(hd0,msdos5)/
error: unknown filesystem
grub> ls(hd0,msdos1)/
lost+found/ memtest86+.bin memtest86+_multiboot.bin memtes86t+.elf /grub

So there's no ubuntu file anywhere. Following, inside of /grub folder there are:

gfxblocklist.txt i386-pc/ locale/ fonts/ unicode.pf2 grubenv grub.cfg

Inside /i386-pc there are dozens of .mod files, just as described in the manual I linked to above. But I cannot find anything like this: ubuntu-14.04.1-desktop-i386.iso

And I had Ubuntu 14.04 installed. Without this, I can't move forward.

Could anyone help?

  • Looks like msdos1 is a boot partition without any kernels. Where was your root partition and what filesystem did it have? Did you have the iso file sitting around on your root? If so where, since that's not a part of a regular install. – ubfan1 Dec 18 '16 at 22:15
  • Hey @ubfan1, thanks for answer! Any hints on how can I get these details that you're askins about now (when the system loads only GRUB)? I don't have them written down anywhere. I had a clean HDD and installed Ubuntu 14.04 on it. I installed the system a while ago, but pretty sure I was just clicking "OKs" throughout the whole installation and I didn't (at least not on purpose) manipulate root location. – xavier_goran Dec 19 '16 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.