2

I SSH into my Ubuntu 16.04 VPS from Windows10 via Putty.

In my system, if I just do nano filename and then / it will exit; If I do so nano filename modify the document even with 1 letter and then do / it will ask me if I want to save changes before exit. You get the idea.

sudo apt-get upgrade && sudo apt-get update && reboot, didn't make any change so it's not a bug and I think I have something fucked up in the system.

Here I didn't find a solution, as it talks about backslashes but not on forward slashes (I can use backslashes just fine). The answer says it's a matter of keyboard layout for the guy but my Windows 10 keyboard layout is first and foremost English-US... And, I now saw that my Ubuntu 16.04 keyword layout is the standard Linux kernel keyboard layout, so I left it as is.

Moreover, the problem doesn't happen in my local WSL-Ubuntu on Win10, so it proves the problem is not keyboard or keyboard-layout related.

The SSH connection is just fine. I basically have no problems with my droplet/sites or anything.

I tried to uninstall and reinstall nano via sudo apt-get purge nano && sudo apt-get install nano. It didn't help as well.

Milestone 1 - The problem seems to be Putty-based:

I host my sites at DigitalOcean.com (DO in short). When I log in to my DO VPS (DO droplet in DO's terminology) from Putty, the problem occurs, but when I log in from the native DO console, the problem does not occur.

Here are my Putty-login's default keyboard settings, I will now try to change them but I paste the original here in any case:

enter image description here

3

Going to features, and checking Disable application keypad mode, in Putty, seems to solve it:

enter image description here

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.