3

I've tried to install Ubuntu 16.04 on my Asus ROG G752VY in dual boot with windows 10. The problem is that Asus ROG G752VY has a PCI Express SSD configured in RAID0 and Ubuntu is not able to see it.

So it is not possible to access Windows partition's data and, even worse, the only way to change the OS to boot is to edit boot sequence in the BIOS.

I'd need help to understand how to deal with this disk.

0

The Asus ROG G752VY appears to be a laptop, I think Matthew Garret wrote about this "RAID issue":

I don't know for sure, but it's potentially related to something I've written about before - recent Intel hardware needs special setup for good power management. The storage driver that Microsoft ship doesn't do that setup. The Intel-provided driver does. "RAID" mode prevents the Microsoft driver from binding and forces the user to use the Intel driver, which means they get the correct power management configuration, battery life is better and the machine doesn't melt.

The real problem here is that Intel do very little to ensure that free operating systems work well on their consumer hardware - we still have no information from Intel on how to configure systems to ensure good power management, we have no support for storage devices in "RAID" mode and we have no indication that this is going to get better in future. If Intel had provided that support, this issue would never have occurred.

So if you are able to change the mode from RAID to the other option (usually AHCI, but that can't be right for NVMe disks). The you would need to reinstall Windows and you would be able to install a Linux distribution of your choice. N.B.: there are a few more issues with .

If you cannot change the mode then that's the end of the road for now.

| improve this answer | |
  • finally I've been able to install linux with all drives correctly mounted by using nvme – Cereal Killer Jan 18 '18 at 0:30
  • @CerealKiller: If you solved your problem yourself, please answer your own question and accept your answer. Don’t put the answer in your question or the comments! :-) – David Foerster Apr 20 '18 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.