0

The audio is scratchy on my new ASUS UX390UA

I have tried everything I could find but nothing seems to fix the problem. I also tried with headphones and am not getting any sound there. The laptop speakers have sound but its very scratchy.

0
sudo vi /etc/modprobe.d/alsa-base.conf
options snd-hda-intel model=generic
sudo restart

This fixed the scratchy audio for me. I had to change the sound settings to use Audio Surround 4.0 output using pavucontrol

This however did not fix headphones. If I plugin headphones audio is still coming out of the laptop speakers.

3
  • This actually made things worse for me. :/ I'm using a UX390UA-77DHDAB1. – pkoch May 17 '17 at 11:56
  • model=auto made it better, tho! – pkoch May 19 '17 at 8:00
  • Installing the intel microcode proprietary drivers also helped. Check out help.ubuntu.com/community/… – pkoch May 19 '17 at 8:01
0

This is what worked for me:

sudo nano /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common

and change this section:

[Element PCM]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

Into this:

[Element Master]
switch = mute
volume = ignore


[Element PCM]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right


[Element LFE]
switch = mute
volume = ignore

save (with Ctrl+x) and reboot

Source: Ubuntu 16.10 on Asus Zenbook 3 UX390 - Ubuntu Forums

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.