I used to run Ubuntu on my old laptop alongside Windows 7, with Ubuntu installed second. Now I want to install Ubuntu 16.04 on my Asus ROG GL553VW. It runs on Windows 10 Home 64-bit, and it has 1TB HDD, 16GB RAM, GeForce GTX 960M and an Intel Core i7 processor.

As per the installation guide page, I downloaded the .ISO file and Rufus. After Rufus has finished processing everything, I restarted my laptop and went to the setup page, setting my USB drive as main boot option and disabling all other options.

This led me to the screen with 'Try Ubuntu without installing', 'Install Ubuntu' and other options. Naturally, I chose 'Install Ubuntu', but the screen froze at the Ubuntu loading screen shown below.

enter image description here

I tried to look for ways to solve this but nothing has worked yet thus far. I have tried to use a different USB, to re'burn' the .ISO file again, changing ports, the 'Try Ubuntu without installing' option, and all of them had no effect. The only solution I have found to be relevant is to use the nomodset option, but I'm not even sure I executed it properly.

  • I have had on occasion, times when Ubuntu would not install from USB for me, and resorted to CD which did work. Do you know if your system is using EUFI or secure boot? It may be that you should enable legacy boot in your BIOS. I would also encourage you to 'Try Ubuntu without installing' first, connect to the internet, and install Ubuntu from the running instance: There is an on-screen icon in the 'Try Ubuntu...' which performs the installation. – Charles Green Dec 17 '16 at 19:18
  • If Windows is UEFI on gpt partitioned drive, you should install Ubuntu in UEFI boot mode. But issue probably is nVidia. You may just need nomodeset to install & first boot, then install nVidia driver from Ubuntu's repository, not nVidia. help.ubuntu.com/community/UEFI and:askubuntu.com/questions/162075/… – oldfred Dec 17 '16 at 20:54
  • I tried secure boot and the installation still froze. As for nomodset, it took me to a login screen and after I found the credentials and logged in, it showed me this – Shironats Dec 18 '16 at 2:57
up vote 41 down vote accepted

I fought with the same problem. I have a brand new Asus GL553VW. I wanted to install Linux but I had to face a lot of problems and still have some. The beauty is that it's a gamer laptop and doesn't really have support for Linux... So, I will write down my past problems and the solution for them.

I had the same freezing issue during the installation. You should go to the grub, where you choose the booting operating system. If it doesn't appear by default, you should press Shift until you see it.

  • Then choose the Ubuntu, or Install Ubuntu (it depends, you will see it hopefully), go to it with the arrows and press the 'e' key.
  • Here go to the line which contains quiet splash at the end and add acpi=off after these words.
  • Then press F10 to boot with these settings.

The installer didn't freeze for me after that. However, you should be aware of that it changes only for the initial boot, after it, when you want to install Linux, you need to change it again.

The next problem I faced was that after booting, in one minute the fans started to scream and work at maximum speed. Other was that the shutdown freezed and I had to press the shutdown key longly. The solution to both of these was to install nvidia. Type in terminal:

sudo apt-get install nvidia

Press tab twice and see which nvidia is the newest. For example, it will look like:

sudo apt-get install nvidia-352

Hopefully it will be the same for you.

Next problem: the fn keys. Only the volume control worked with it. Unfortunately I haven't find an exact solution yet. I'm trying, but it would need a driver, which I'm afraid doesn't exist. However, I set my shortcuts in settings and after that, at least for instance the brightness control works (but with another key combination). The only bug which I faced then was that the keyboard backlight doesn't work whatever I do (in Windows, it's perfect after the installation of drivers from the given CD). I'm trying to solve it. Hopefully I will find a way to bring it to life. I haven't found any other bugs yet, and I hope I won't. I haven't started to use it really...

Hope I could help you! :)

  • Good news! I found a solution (well, not so professional, but at least it works) for the keyboard backlight. I have dual boot. In Windows, I can manage the brightness with the fn keys. I found accidentally: I rebooted from the win menu with backlight on and it remained lit! Even after Kubuntu booted! I still can't control the brightness in Linux, but I'm happy that it works at all. Maybe if you look up some other forums, you can find a better solution. There are a plenty of them. But be aware: writing acpi_osi in the grub file made an even bigger, permanent bug for me (eg. touchpad cases). – Blanka V. Jan 11 '17 at 17:12
  • This solution worked for me with Ubuntu desktop 17.04. Thanks. – Mena Jun 8 '17 at 10:15
  • 3
    It did work for me too, actually. Make sure you add acpi=off directly after quiet splash, with a space in between splash and acpi. – wordsforthewise Nov 16 '17 at 21:37
  • Thanks! This worked for me with 17.10.1 too :) – dumazy Jan 20 at 10:22
  • 1
    If you are on a Dell, change your SATA operation mode to AHCI in the BIOS first, then apply this answer before live USB boot-up. I was able to boot now, yet during installation no hard disk was found as it was in RAID mode. askubuntu.com/questions/696413/… – k0pernikus Feb 14 at 13:38

My situation (HP zBook ZBook 15 G3) is to disable the Disable Hybrid Graphics in BIOS, no need more GRUB editing.

  1. Press F10 (for HP) immediately and repeatedly when the system boot, and you will go to BIOS setup utility.
  2. Go to Advanced -> Built-In Device Options (or Device Configurations in G1 and G2)
  3. Select Discrete Graphics for Graphics. (Default is auto), and save and exit. discrete Graphics

What I've done additional is enable the Virtualization Technology and disable the Fast Boot.

  1. BIOS setup utility -> Advanced -> System Options:
    • check: Virtualization Technology (VTx)
    • check: Virtualization Technology for Directed I/O (VTd) vtx&vtd
  2. BIOS setup utility -> Advanced -> Boot Options:
    • uncheck: Fast Boot fastboot

By the way, I didn't disable the Secure Boot Configuration like some of post shows. Here my settings for your reference: secure boot conf

Here more references:

  • Host: HP zBook ZBook 15 G3
  • Ubuntu OS: Ubuntu 18.04 LTS
  • Using USB install. USB image created from OSX, etcher.app.

protected by Community Dec 30 '17 at 12:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.