3

I have an old C program (2003) of about 1600 SLOC written not by me. I compile it with gcc without flags.

The problem is that the Files program shows icon of a text file instead of an executable file and Ubuntu doesn't think that it's a executable at all. I've tried chmod +x, chmod 777 and permissions tab of file's properties in Files (which probably uses chmod anyway) but nothing changed.

When I double click the file I get the message "there is no application installed for "shared library" files".

I can run it from the console with ./ and it works correctly.

Also, actually I want not to run this program but give it to another application which would use this program. I can't do it because this application uses standard (as it seems) Ubuntu "Select file" window and file format is set to "Executable files" so I can't see my program in it.

I believe if I could see it both programs would run together correctly.

closed as unclear what you're asking by mikewhatever, Jacob Vlijm, Eric Carvalho, Byte Commander, Kaz Wolfe Dec 25 '16 at 2:47

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

4

There has been a change of the way Nautilus handles executable files by default. Previously, it asked you what to do when you double-click one. Now, it tries to open the file using an application.

The get the dialog where you're given the option to execute the file, open Nautilus, go to Edit → Preferences → Behavior and toggle Executable Text Files to Ask each time. This previously was the default. But now it's "View executable text files when they are opened" which means that Nautilus searches for an application to open the file with when you double-click it but can't find one for that file type.

I don't recommend toggling it to Run executable text files when they are opened so you don't accidentally execute files.

  • Does not work on 18.04, even after rebooting. I set it to "Run every time" and still get the popup about "shared library files" as described in the OP. – Jack M Dec 25 '18 at 13:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.