1

After upgrading from 14.04 (with fglrx) I am having trouble with OpenGL. I had to add the Padoka PPA since it supported OpenGL 3.3 (also GLSL 1.3). After adding the PPA I have OpenGL version 4.1 but not version 4.5 like with fglrx. But GLSL is still 1.3 (with fglrx it was 4.3).
I am having problems with some effects that are not working in SuperTuxKart (which require GLSL 3.0) and Minecraft SEUS lite shaders is also not working (which require GLSL 1.40 or 1.50).

  • How can I upgrade the GLSL shaders version to 4.1?
  • Is this a limitation of Mesa or something that I can fix?
    My system specifications are:

    HP Pavilion g7 2269wm
    CPU : AMD A8-4500M APU
    GPU : AMD Radeon HD 7640G (can play SuperTuxKart smoothly on settings between medium and high. Minecraft gets 60FPS :)

  • Have you considered dual-booting to allow for the best of both worlds? This would allow you to run fglrx under 14.04 when you needed to without giving up your current 16.04 installation. Perhaps I'm oversimplifying, but logic dictates that since you were where you wanted to be before, going back is an option. Since a 14.04 installation takes up a very small fraction of any current storage media it would seem a small price to pay to obtain what you want. I've searched and can't find a better option for you. Best of luck! – Elder Geek Dec 29 '16 at 17:43
1
+100

After looking at several,

posts:

And this article:

The best Ubuntu version is 14.04 and any planning to use fglrx would fare better sticking with Ubuntu 14.04.

The ‘Xenial Xerus’ will not support the widely used — and widely hated — proprietary graphics driver for AMD/ATI graphics cards.

Instead, Ubuntu “recommend[s using] open source alternatives (radeon and amdgpu)”, and say “AMD put a lot of work into the[se] drivers, and we back ported kernel code from Linux 4.5 to provide a better experience.”

Phew, right?

Well kinda.

Rough edges with the (newly recommended) open-source replacements could mean that some upgraders will encounter poorer performance under 16.04 than in Ubuntu 14.04 LTS or 15.10.

source: http://www.omgubuntu.co.uk/2016/03/ubuntu-drops-amd-catalyst-fglrx-driver-16-04

From the second answer in this post

If you are running a 14.04 installed prior to 14.04.5, and continue installing standard updates, but DO NOT install the lts-xenial HWE stack by hand, then fglrx should continue to work, even though the About information in System Settings and elsewhere, will say that you have 14.04.5.

The important part is to NOT be running the lts-xenial kernel and xorg packages, to get fglrx to work.

Basically what this means is if you want the latest version and best performance:

  1. Stay away from Ubuntu 16.04 if you wan to continue to use fglrx
  2. If you want to, then take care to install the right Ubuntu 14.04 version so an upgrade will work as well.

Hopefully these resources will help you determine how best to continue using fglrx in your Ubuntu version and if an upgrade will work best.

A good installation guide can be found in this post for Ubuntu 14.04

| improve this answer | |
  • So you are telling me the only solution is to go back to 14.04. Is there any patch or something to the Mesa source code to fix this – Suici Doga Dec 25 '16 at 11:02
  • Yes, as stated in their official documentations and other sources. Its a proprietary and non-proprietary issues as far as I know. – George Udosen Dec 25 '16 at 11:11
  • How can I contact to Mesa dev team and tell them about this ? – Suici Doga Dec 25 '16 at 16:02
  • Try forum and dev team – George Udosen Dec 25 '16 at 16:27
  • 2
    I asked them on IRC and they said that it is intentional though blobs and windows drivers support and that Minecraft should request a core context if it wants more features. So maybe the only solution is to write a mod that makes it use a core context – Suici Doga Dec 29 '16 at 14:16
0

I don't believe that at this moment you can upgrade the GLSL shaders version to 4.1 given your current installation and the current state of the mesa drivers.

Currently The Mesa 3D Graphics Library supports version 3.30 of the shading language via the stand alone GLSL compiler.

Whether you can fix this yourself or not depends on your skill set.

The source code for Mesa's shading language compiler is in the src/glsl/ directory. Download locations and unpacking instructions are available here

If you are able to meet your goals via modification of the code The development team would love to have your help.

Update: Mesa 13.0.1 implements the OpenGL 4.4 API, but the version reported by glGetString(GL_VERSION) or glGetIntegerv(GL_MAJOR_VERSION) / glGetIntegerv(GL_MINOR_VERSION) depends on the particular driver being used. Some drivers don't support all the features required in OpenGL 4.4. OpenGL 4.4 is only available if requested at context creation because compatibility contexts are not supported.

Sources:

http://www.mesa3d.org/shading.html

http://www.mesa3d.org/relnotes/13.0.1.html

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.