3

by running xfce4-power-manager --no-daemon --debug in a terminal window, I can see why my screen never sleeps: Chrome (beta) is sending many inhibit messages, nested even. Some are not turned off via 'UnHibit'.

For example: as soon as chrome starts:

Inhibit send application name=/usr/bin/google-chrome-stable reason=WebRTC has active PeerConnections sender=:1.202

Opening gmail seems to generate this WebRTC message too. There is no unhibit message, ever.

Some of these reasons shouldn't stop screen blanking, but xfce4-power-manager stops all power management activities when it receives an inhibit message.

Can I stop Chrome from doing this, or set xfce4-power-manager to ignore inhibit messages from Chrome?

I can't find a chrome setting for this. I see this with Chrome stable and beta. The version of Chromium in the Ubuntu repositories is v53 and does not have this problem.