I want to connect via remote desktop to a Windows Server 2008 R2.

On the Windows server's remote desktop connection properties, it is set to "safer". Specifically, the selected option is "Allow connections only from computers running Remote Desktop with Network Level Authentication."

On my Ubuntu system, I tried using Remmina to connect to the Windows server. Remmina can not connect to that server with the option "Network Level Authentication" (as mentioned in the previous paragraph). The error message Remmina returns is as follows:

Disable the connection to the server RPD: IPWINDOWSSERVER2008

How can I connect Remmina (or another program) by remote desktop to a Windows Server 2008 host with the "Network Level Authentication" option selected?

11 Answers 11


As of Ubuntu 12.04, you can use Remmina to connect to Windows servers with Network Level Authentication enabled.

sudo apt-get -y install remmina

Remmina uses FreeRDP for RDP connections and NLA support was added to FreeRDP in version 1.0, which is available to Ubuntu 12.04 and above. If you happen to be using an earlier version of Ubuntu and cannot upgrade, here's an updated version of remmina here, although I can't vouch for its stability: https://launchpad.net/~freerdp-team/+archive/freerdp

If that doesn't work, you might be able to connect directly:

  1. Install the above PPA
    sudo apt-add-repository ppa:freerdp-team/freerdp
  2. Install the freerdp package:
    sudo apt-get install freerdp
  3. xfreerdp --plugin cliprdr -g 1024x768 -k no -u {username} -d {domain-name} {target-machine}

If you do the latter, you can can always create an alias in ~/.bash_aliases:
alias rdp='xfreerdp --plugin cliprdr -g 1152x864 -k no -u username -d DOMAIN'

  • When I tried it, FreeRDP worked with NLA and is in the Ubuntu 13.10 repositories. Commented Dec 16, 2013 at 22:40
  • This works great also on Arch Linux. Thank you! I now can keep my Windows machine with the security of "Network Level Authentication".
    – strpeter
    Commented Nov 12, 2014 at 20:04

I solved this issue by right clicking on the entry in Remmina, going to edit, clicking on the advanced tab, and then changing the security field to "RDP" from "Negotiate"

  • using default settings on Ubuntu 16.04.1 RDP didn't worked for me and default Negotiate did the job where Network Level Authentication was enabled on server.
    – Xaqron
    Commented Feb 13, 2017 at 0:56

New command formatting

After my last update, I got confronted with FreeRDP 1.2.0 (probably it changed already with version 1.0.2 - and got though also relevant for most Ubuntu users). Its protocol changed how to connect. Try the following example:

xfreerdp /u:<username> /v:<hostname> /size:<WxH>

Additional features

There are a lot of features you might want to discover on the development page https://github.com/FreeRDP/FreeRDP/wiki/CommandLineInterface


I solved problem on 13.04 with setting TLS when connecting to Windows 2008 R2 Enterprise server. Auto-negotiation didn't work.

  • When answering a question, please give a description of the steps you took to fix the problem, and as much information as you can offer.
    – Simon
    Commented Sep 13, 2013 at 10:39

I was unable to connect with remmina, finally tried freerdp from the command line:

xfreerdp [serverip]

I was prompted for my password, then received the message that the host key for this IP had changed. I deleted the known_hosts file (~.freerdp/known_hosts) and remmina was able to connect.


I know this is old but I had same problem in 12.04 remmina and solution was setting security to RDP. I don't know why "auto" doesn't work.

  • Sorry, but care to edit your answer and elaborate?
    – Braiam
    Commented Aug 29, 2013 at 11:42

It doesn't work with NLA for me either. You can set the Windows Remote Desktop to the middle option (without Network Level Authentication) and then it works.

If you are on a local area network and ports are behind a firewall for the outside world, it shouldn't be too insecure.


Have you tried using Wine?

DL this and run it on wine. (http://www.microsoft.com/downloads/details.aspx?FamilyID=80111F21-D48D-426E-96C2-08AA2BD23A49&displa)



For me it worked with (even on Windows Server 2012) using: Sound: Local Security: Negotiate Attach to console: Checked


If Remmina previously worked, the certificate on the server may have been changed.

To check this, go in your home directory into the subdirectory .freerdp, have a look at the file known_hosts, and compare the certificate fingerprint. If the fingerprint differs, you can change it to the new one.

Of course, You should double-check that the fingerprint is correct and not manipulated. If you are within a secure environment, you may alternatively delete the belonging line in known_hosts. A new one will appear during the next connection.


I set the security option to 'negotiate' instead of 'NLA' and directly got me connected. Before that I was not able to connect with proper credentials. Kept saying 'Wrong username or password' knowing the password was correct.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .