0

I have a problem that at first looks similar to the one here:

How to use a bluetooth headset mic in Ubuntu?

After working on this for hours, I was grateful to come across that webpage, giving hope. My Agptek headset (no Dongle -- just Bluetooth direct to a Lenovo Thinkpad) worked fine on Windows 8.2. When I changed the O/S on the machine to Ubuntu 16.04 LTS, I got symptoms similar to those at the above link: the headphones only worked in A2DP, and, if I change the input sound source (from Thinkpad's internal mic to Agptek's mic) then the input and output sound both stop working. So, in Ubuntu my headset is basically reduced to a pair of headphones, with no mic.

Interesting to learn at the link above that HSP/HFP has to work in order for the mic to work. I'm still new to this.

The output of lsusb is:

Bus 002 Device 002: ID 5986:0299 Acer, Inc 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 0a5c:21f3 Broadcom Corp. 
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 004: ID 045e:00db Microsoft Corp. Natural Ergonomic Keyboard 4000 V1.0
Bus 005 Device 003: ID 1a7c:0192 Evoluent 
Bus 005 Device 002: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I have PulseAudio Volume Control and I use the standard Bluetooth system that comes with Ubuntu. I tried Blueman to get around this problem, but that didn't work so I restored the desktop to default settings again.

Any ideas on next steps? Thanks very much.

  • 2
    In a terminal, type alsamixer, select Capture (mic) by pressing F4, then select the soundcard with F6, and check if the mic volume is on. Use keyboard arrows to move around and change volume. – user308164 Dec 16 '16 at 15:19
  • Thanks for the quick reply! When I pressed F4, I got "This sound device does not have any capture controls." When I pressed F6, three options appeared: – M. Ebden Dec 17 '16 at 18:31
  • (-) default, (0) HDA ATI HDMI, (1) HD-Audio Generic – M. Ebden Dec 17 '16 at 18:32
  • When I selected '0' nothing happened but when I selected '1' I was able to increase the 'Mic Boost' from above 0, using the keyboard arrows. – M. Ebden Dec 17 '16 at 18:32
  • Unfortunately the mic still wasn't working after that. In sound settings, I then tried changing the headset output from AD2P Sink to HSP/HFP and back but this didn't help. Thanks again for any other ideas, and please forgive the odd paragraphing above -- I'm new here and don't know how to force line breaks in Comments. – M. Ebden Dec 17 '16 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.