30

Please could you tell me where can I find the File Manager Preferences in Ubuntu ... (now for 16:04 LTS).

The menu bar has disappeared from Nautilus, as also have the resize handles and the top-bar right-click menu (except for 'Close'). The window gets a little smaller every time I open it, it's gradually disappearing and I can't presently correct it.

I'm using Gnome not Unity, so the fixes for unity don't work.

I would have preferred to add these observations as comments, but I still have too few reputations to do that, so have to ask a new copy of the same question instead.

nautilus window

Left-hand desktop complete

  • 2
    Possible duplicate of How to open Nautilus (File Manager) preferences? – M. Becerra Dec 16 '16 at 15:16
  • 2
    It's in the app menu dropdown, i.e. click Files at top left – doug Dec 16 '16 at 15:36
  • I do not have an app drop-down menu ... that's precisely the problem. – Gordon Dec 16 '16 at 16:13
  • How, please, do I get back the missing menu so I can do that? – Gordon Dec 16 '16 at 16:17
  • 2
    You don't have something similar to this? (in your case would probably be "Files", not File Manager - imgur.com/a/vQUal – doug Dec 17 '16 at 1:05

10 Answers 10

15

On Ubuntu 17.10.1, the top left corner of the screen next to Activities, you'll find Files with a drop-down arrow:

screen shot

Click on Files, then in the list that appears, click on Preferences.

10

For Gnome

It appears that you made an ill-advised change with the Tweak-tool in Gnome. gnome-tweak-tool is available for all currently supported versions of Ubuntu and is readily installable by activating the Universe repository and installing it via Software Center or via the command line with sudo apt-get update&&apt-get install gnome-tweak-tool

Open it (via terminal if necessary with gnome-tweak-tool Navigate to Top Bar and flip "Show Application Menu" toggle to ON. This will return the Files button to your top bar menu where you can access Preferences.

For Unity or Mate DE's In Ubuntu 14.04 and 16.04 you can simply use the key combination Alte and then n This will open the preferences menu which looks like this:

nautilus-prefs

For Kubuntu (Plasma DE)

AltF3 and "More Actions" Brings up most preferences in Nautilus. If what you are looking for isn't there try the Menu button in the upper right corner of the window.

For Lubuntu (LXDE DE) Not a lot here, Options available from the V button near the upper right corner of the window.

  • 2
    Hmm, The votes-up suggest that's worked for other people. I didn't work for me. The first observation is that I didn't have the gnome-tweak-tool installed, do I installed it and went to the relevant place. The option was already On. I've tried a selection of On/Of switching and some close and re-open on Nautilus, but so far to no avail. I have yet to try log-out/log-in/reboot. I haven't managed to get the other suggestions to do anything useful, but then I think they don't apply to this desktop manager, so that's no surprise. :-) – Gordon Dec 27 '16 at 23:00
  • I've tried a selection of log-in/out/reboot, no change. I can't presently be sure what the option is trying to do ... put the menus on the window top bar or put them or the desktop top bar. At present I can find absolutely no guidance at all about what the tool does, though I can guess at quite a bit. No significant help, no man-page, no hover tool-tips, nothing. – Gordon Dec 27 '16 at 23:14
  • What version of Ubuntu-Gnome are you running? You indicated 16.04... I know the tweak tool is included in the current ISO as I booted it to develop the instructions. Updated answer. – Elder Geek Dec 28 '16 at 13:55
  • Hmm. It's a recent installed-from-scratch 16:04LTS Desktop with Gnome flashback (IIRC), as I strongly dislike Unity. I'm not sure how to be certain what Gnome is, but gnome-flashback is "3.18.2-1ubuntu1" according to Synaptic. It's an install from scratch as, unusually, the distro-upgrade wrecked the old installation. Sigh ... Ho Hum. – Gordon Dec 28 '16 at 14:07
  • Oh ... metacity. – Gordon Dec 28 '16 at 14:15
5

For 18.04, Gnome (for other desktops, see below):

The same as for 17.10 - as seen in the other answer.

enter image description here

When Tweaks tool is used, especially with various extensions, in order to have the above option be sure App Menu is not disabled, including in per-extension settings.

For example, with the Dash to Panel extension, which creates an all-in-one dock/panel (the dock is merged into the panel) and brings the favorite and running applications icons onto the panel, you have a specific settings button under which you can enable/disable App Menu:

enter image description here

But, with the same extension, as App Menu is not really needed anymore, it can be disabled without losing access to the Nautilus settings, as the Nautilus/Files icon that now appears onto the panel (when the program is opened) has the "Preferences" option in the right-click context menu:

enter image description here


The Nautilus settings are also available as gsettings, editable through dconf Editor - as already indicated by this answer - at the level org.gnome.nautilus.preferences:

enter image description here


Outside Gmome, namely in Ubuntu Budgie, the left-corner button that gives access to those options (but which is missing in Ubuntu 18.04 Gnome) is not missing with the same version of Nautilus 3.26.3.

enter image description here

enter image description here

1

For Gnome Flashback

If you have Gnome Flashback installed like this, then logout from Gnome and switch to Unity as shown in the picture below. Now you can edit Nautilus Preferences. After finishing switch back to Gnome and you're done. It is not the easiest way, but you won't have to install other stuff.

How to switch between Gnome Flashback and Unity

1

I got the same question on Xenial (16.04) but none of the other answers worked for me.

I found that you can edit nautilus preferences with the dconf-editor tool. The offending section is in org.gnome.nautilus.preferences.

Unfortunately, some options may not be editable (that was my case with a drop-down list that was not allowing correct keys). In that case, you may use the following command: gsettings org.gnome.nautilus.preferences <KEY> <VALUE>.

  • To complete this, for example, to change the default sort order to have the latest modified files at the top, one would execute these two commands: gsettings set org.gnome.nautilus.preferences default-sort-order 'mtime' followed by gsettings set org.gnome.nautilus.preferences default-sort-in-reverse-order true Also, one can obtain more information on the possible values with this: gsettings range org.gnome.nautilus.preferences default-sort-order – Louis Gagnon May 8 at 9:35
1

Using 18.04. I couldn't find the settings menu. It was an extension that was hiding the menu: Dash to Panel As soon as I turned it off, it was easy to locate.

0

I have at least a partial answer to this.

Removing appmenu-qt5 has restored the menu bar. I still have no gear-wheel icon, but I can now access the menu Edit->Preferences.

But ... I've now lost the menu bar from a number of other applications, despite restoring appmenu-qt5, however all those I have so far tried pop up the menus upon a right-click on the background. Consistency would be nice, but at least it's working.

I notice the two tools have different themes ... there must be a clue there!

Screenshot of Gimp, Nautilus and top-bar on XUbuntu

  • I just thought I'd add a bit to this. The short answer is that I gave up on standard Ubuntu and switched to XUbuntu instead. I haven't seen the problem since. – Gordon Nov 6 '17 at 20:55
0

I had the same issue, but I realized that maximizing the window and moving the mouse pointer over the top bar makes file options to appear. Hope it helps.

0

I have Ubuntu Gnome 16.04. I have the panel on the bottom just like you do. When Nautilus/Gnome Files is open I just right click the icon in the panel to get the "Preferences" menu.

Nautilus Menu

-1

I am using 16.04, finally I solved it. You should install the software namely 'nautils-actions'(in synaptic), then in tweak tool enable application menu in top bar. Finally, you will reach there:

  • what nautilus-actions has to do with this? – user47206 May 2 '18 at 7:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.