1

I need to run some analyses in R 2.14 (this old version is needed to run an old package). I'm using 64-bit Ubuntu 16.04 LTS. I need the quantreg packag in R. But this gives me some error: liblapack.so.3gf and libblas.so.3gf are not found.

> lien@lien:~/R/x86_64-pc-linux-gnu-library/2.14/quantreg/libs$ ll
drwxr-xr-x  2 lien lien   4096 déc.  12 11:45 ./
drwxr-xr-x 10 lien lien   4096 oct.  16  2012 ../
-rw-rw-r--  1 lien lien      0 déc.  12 11:45 export
-rw-r--r--  1 lien lien 254176 déc.   8 16:51 libblas.so.3
lrwxrwxrwx  1 root root     31 déc.  12 09:43 liblapack.so.3gf -> /usr/lib/R/lib/liblapack.so.3gf
lien@lien:~/R/x86_64-pc-linux-gnu-library/2.14/quantreg/libs$ ldd quantreg.so 

This is the output of the "ldd quantreg.so" - linux-vdso.so.1 => (0x00007fff435fc000) - liblapack.so.3gf => not found - libblas.so.3gf => not found - libgfortran.so.3 => /usr/lib/x86_64-linux-gnu/libgfortran.so.3 (0x00007f3a65cf9000)

  • libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f3a659f0000)

  • libR.so => /usr/lib/libR.so (0x00007f3a6543e000)

  • libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f3a65074000)
  • libquadmath.so.0 => /usr/lib/x86_64-linux-gnu/libquadmath.so.0 (0x00007f3a64e35000)
  • libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f3a64c1f000)
  • lib64/ld-linux-x86-64.so.2 (0x000055780a4b9000)

  • libblas.so.3 => /usr/lib/libblas.so.3 (0x00007f3a649e0000)

  • libreadline.so.6 => /lib/x86_64-linux-gnu/libreadline.so.6 (0x00007f3a6479a000)

  • libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f3a6452a000)
  • liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007f3a64307000)
  • libbz2.so.1.0 => /lib/x86_64-linux-gnu/libbz2.so.1.0 (0x00007f3a640f7000)
  • libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f3a63edd000)
  • librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f3a63cd4000)
  • libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f3a63ad0000)
  • libgomp.so.1 => /usr/lib/x86_64-linux-gnu/libgomp.so.1 (0x00007f3a638ae000)

  • libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f3a63690000)

  • libatlas.so.3 => /usr/lib/libatlas.so.3 (0x00007f3a630f2000)
  • libtinfo.so.5 => /lib/x86_64-linux-gnu/libtinfo.so.5 (0x00007f3a62ec8000)

However, both packages libblas and liblapack are installed:

> lien@lien:~/R/x86_64-pc-linux-gnu-library/2.14/quantreg/libs$ dpkg -l | grep 'openblas\|atlas\|lapack' 
ii  libatlas3-base   3.10.2-9         amd64      Automatically Tuned Linear Algebra Software, generic shared 
ii  liblapack3       3.6.0-2ubuntu2   amd64      Library of linear algebra routines 3 - shared version

I already tried making a lync for liblapack.so.3gf but this also doesn't work. I don't have a lot of experience with Ubuntu, and don't really know what else I can try.

  • I realized now that I was running the package before on Linux 14.04 and that worked like a charm. Since I upgraded to Ubuntu 16.04 the problems started. Are there special requirements to run libblapack and libblas in Ubuntu 16.04? – slien Dec 16 '16 at 15:35
1

On ubuntu 16.04 installing the packages liblapack3 and libblas3 should fix your issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.