2

I have Observium installed on my Admin Cloud instance, I also need to add Bugzilla on to this server.

I have installed Bugzilla successfully - /var/www/html/bugzilla Observium - /opt/observium

I have setup the conf like this:

/etc/apache2/sites-available/bugzilla

 <VirtualHost *:8080>
     ServerName bugzilla
     ServerAdmin webmaster@localhost
DocumentRoot /var/www/html/bugzilla
<Directory />
       AddHandler cgi-script .cgi
       Options +ExecCGI
       DirectoryIndex index.cgi index.html
       AllowOverride All
</Directory>
ErrorLog  ${APACHE_LOG_DIR}/error.log
LogLevel warn
CustomLog  ${APACHE_LOG_DIR}/access.log combined
ServerSignature On

and

/etc/apache2/sites-available/observium.conf

 <VirtualHost *:80>
ServerName observium
ServerAdmin webmaster@localhost
DocumentRoot /opt/observium/html
<Directory />
        Options FollowSymLinks
        AllowOverride None
</Directory>
<Directory /opt/observium/html/>
       Options Indexes FollowSymLinks MultiViews
       AllowOverride All
       Require all granted
</Directory>
ErrorLog  ${APACHE_LOG_DIR}/error.log
LogLevel warn
CustomLog  ${APACHE_LOG_DIR}/access.log combined
ServerSignature On

And added Listen 80 & Listen 8080 in ports.conf

But the only site available is obsevium.

Have a missed something??????

Thanks :)

4
  • Isn't http://bugzilla:8080 working?
    – pa4080
    Dec 15, 2016 at 12:26
  • No, it searches then, The connection has timed out It's a cloud server so can't access like that. Dec 15, 2016 at 12:37
  • Is the port 8080 open into the firewall?
    – pa4080
    Dec 15, 2016 at 12:43
  • Maybe you may rename .conf file from /etc/apache2/sites-available/bugzilla to /etc/apache2/sites-available/bugzilla.conf and execute a2ensite bugzilla.
    – pa4080
    Dec 15, 2016 at 12:57

2 Answers 2

1

you can add multiple sites via adding host entries in host file

/etc/hosts
2
  • Thanks but i did that - 127.0.0.1 localhost observium bugzilla Dec 15, 2016 at 12:23
  • Are they all on one line ? Dec 15, 2016 at 13:21
0

You need to enable the new configuration, then reload apache. I would recommend renaming your bugzilla to bugzilla.conf. You can copy the default one and rename it.

sudo a2ensite bugzilla

or

sudo a2ensite bugzilla.conf

Reloading Apache

sudo service apache2 reload

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.