3

enter image description here

I added some input methods using IBus before. After I upgraded to Ubuntu 16.04, though, they stopped working. (If I select them I just get normal English input.) I just want to get rid of them now, but I don't know how.

I tried going to System Settings > Text Entry but the mongolianipa and MongolUnicode ones that I want to get rid of are not listed.

enter image description here

Where is the menu generated from? Is there some settings file or database that I can edit?

Update

If I try re-adding the the MongolUnicode input method, it seems to work fine, even though there was a warning:

/usr/share/ibus/setup/main.py:38: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded. from gi.repository import Gtk /usr/share/ibus/setup/main.py:39: PyGIWarning: IBus was imported without specifying a version first. Use gi.require_version('IBus', '1.0') before import to ensure that the right version gets loaded. from gi.repository import IBus

The only noticeable problem is that it creates a double entry in the menu.

enter image description here

I am able to input text with the new input method. When I remove the input method in Text Entry Settings it disappears from the menu. However, the old one is still there in the menu.

Note 1

As a part of the installation process, a new database appears to be created:

sudo ibus-table-createdb -n /usr/share/ibus-table/tables/Mongol_Unicode.db -s /path/to/Mongol_Unicode.txt

I'm wondering if this database or an old one got corrupted at some point. Where can I find this database? Can it be edited?

Note 2

I'm not able to add a new input method using the standard way to add a custom layout (as described here and here). When I try I only get a gray menu item (similar in appearance to the ones above that I am trying to remove) that does not input the characters in the custom layout, only the standard English input characters.

  • Can you re-add them? If so, do two appear or is there only one? What happens if you remove the entry you just added? – Kaz Wolfe Sep 26 '17 at 18:04
  • @KazWolfe, I updated my post with the results of your suggestion. – Suragch Sep 27 '17 at 3:09
1

I have the exact the same problem, but I solved this issue....

First , in the new Ubuntu 16.04, you need to install the dconf editor, you can do this by entering :

sudo apt-get install dconf-editor

Second, once the software installed, open it and then go to "org.gnome.desktop.input-sources"

on the "sources" you will see something like this.

[('xkb', 'us'), ('ibus', 'anthy'), ('ibus', 'cantonhk'), ('ibus', 'quick-classic'), ('ibus', 'table:cantonhk')]

(my problem is the 2nd one, "cantonhk" and "quick-classic", like your issue occured)

Third, click on that line and delete the item your have problem.... my ones then becomes....

[('xkb', 'us'), ('ibus', 'anthy'), ('ibus', 'table:cantonhk')]

Finally, close the editor and reboot the machine....

Then you will get out of this issue.

Hope this helps...

  • My problem seemed to go away when I upgraded to Ubuntu 18.04 but that is good to know about dconf-editor. Since it worked for you I am marking this as accepted. – Suragch Dec 23 '18 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.