11

I have a problem with my display controller it says "Unknown Display", so I can not get the right resolution.

This is my hardware:

$ lspci|grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)

Does anyone know how can I fix it?

16

I found an alternative way to get the resolution I wanted, what I did was use xrandr to create the new resolution I wanted, so even though it still says unknown display I have the option to select the correct resolution, and the screen looks perfect now.

In my case I needed the 1360x768 resolution (it only gave me the option for chosing 1024x768 or 800x600)

so here is how I got the right resolution:

alex@Minx:~$ xrandr
Screen 0: minimum 8 x 8, current 1024 x 768, maximum 32767 x 32767
HDMI1 disconnected (normal left inverted right x axis y axis)
VGA1 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00* 
   800x600       60.32    56.25  
   848x480       60.00  
   640x480       59.94  

VGA1 is my device, then I created the resolution I wanted

alex@Minx:~$ sudo cvt 1360 768 60
# 1360x768 59.80 Hz (CVT) hsync: 47.72 kHz; pclk: 84.75 MHz
Modeline "1360x768_60.00"   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync

Created a new mode for my resolution:

alex@Minx:~$ xrandr --newmode "1360x768_60.00"   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync

Finally added the new mode to my VGA1 device:

alex@Minx:~$ sudo xrandr --addmode VGA1 1360x768_60.00

Then I went to Displays and was able to select the 1360x768 resolution.

7
  • Why 84.75 1360 1432 1568 1776 768 771 781 798 -hsync +vsync ? – Black Jun 21 '17 at 7:10
  • Might help someone: By creating a ~/.xprofile file with the xrandr lines one can preserve the setting after restart. (change the lines to match your configuration): xrandr --newmode "1920x1080" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync && xrandr --addmode eDP-1 1920x1080 use "cvt 1920 1080 60" to get the --newmode line. Source : bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1517046/… – Vikas Swami Aug 24 '17 at 4:10
  • @Black sorry about the delay, it's because that's what cvt for the resolution I want generates as modline, so then when you create the mode to the device you use it – alexm Nov 14 '17 at 19:10
  • working but display revert back to low resolution after restart – Killer Dec 6 '17 at 4:47
  • @killer I'm not sure why that is happening probably w permission issues on a config file. 1) update and upgrade the system, actually after I upgraded to later version problem stopped happening 2) do a sudo su, do it again and restart. 3) worst case scenario, make a bash file with the commands and add it to start up routine – alexm Dec 6 '17 at 10:04
1

I solved it by plugging the DVI cable in and out. Then I went to system settings -> display settings and pressed on the "detect screens" button.

That solved my problem

1
  • 1
    On a 16.04 I had a similar issue after a system update but solved it merely by turning the monitor off then on (pressing on/off on front display) - without having to plugging the cable out/in. Marginally easier. – user3375672 Dec 10 '17 at 12:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.