0

I use the default backup utility of Ubuntu 14.04. Backup files are stored in an external USB3 disk, when it is connected.

On this Ubuntu system I have VirtualBox installed, which runs an old Windows XP virtual machine.

The issue

The .vdi disk of this VM was badly corrupted after today's session (I don't know why, it looks like a Win issue) and I would like to recover it entirely from the backup.

So I looked for a suitable function in the backup GUI, but there seems to be no way to restore a single file by "point & click"

So I tried from the command line, after first renaming the corrupted file

$ cd ~/VirtualBox VMs/VirtXP
$ mv VirtXP.vdi VirtXP.vdi.corrupt

First attempt

$ deja-dup --restore VirtXP.dvi

This opens the GUI and leads to a list of possible dates from where to choose, with at least many lines. After I select one (the second to last), it takes a long "Preparation..." time, then it tells me that the "restore is impossible, as the file cannot be found in the backup".

Second attempt

$ deja-dup --restore-missing .

In this way, it also shows a - rather different - listing, which despite the long long time spent and the messages ("Analysing files of seven months ago..."), only includes a single line. (BTW, this is the same dialog that I reach from Nautilus' Restore Missing Files....).

The problem is, that this file is too recent. In fact it is from only a couple of hours ago: the backup utility must have backupped the file after it was already corrupted! So I don't need this file.

The Question(s)

I must miss something.

I can't believe that simply by plugging in the external HD, a new backup was triggered that overwrote the old (good) files with the new (corrupted) ones. Maybe that would be correct with files backupped more than three months ago, but it is obviously wrong to overwrite yesterday's backup with today's files.

How can I reliably find the 2nd-last backupped versions of that .vdi file?

How can I recognize and/or fix an eventual misconfiguration issue?

Thank you very much

0

I must admit that part of the issue was due to mistyping filenames.

Partial answer:

As you can see above I mistyped .dvi for the extension instead of .vdi. That was the reason for the first attempt being unsuccessful.

In fact I could find an old-enough backup file with the following duplicity command:

$ duplicity list-current-files -t 3D file:///media/user/TOSHIBA\ EXT/backup_home_user | grep .vdi

which succesfully found the file:

Fri Dec  9 09:56:13 2016 home/lorenzo/VirtualBox VMs/VirtXP/VirtXP.vdi

Based on this I tried, again via duplicity:

$ duplicity restore --file-to-restore VirtualBox\ VMs/VirtXP/VirtXP.vdi -t 3D file:///media/user/TOSHIBA\ EXT/backup_home_user ./restoreDir

...which unfortunately led to the request of the "GnuPG Passphrase", which I couldn't remember.

So I stayed with deja-dup and issued the following command again (this time with the correct .vdi extension):

deja-dup --restore VirtXP.vdi

... hence, after selecting the 9-Dec date, the recovery was succesfully completed.

There still remain two questions:

  • why can deja-dup work without a passphrase, and (how) can I recover it?

  • why didn't the second attempt (--restore-missing) work? (no wrong filename there)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.